A few issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-07-2011, 08:34 PM
Member
 

Join Date: Feb 2011
Location: Aliquippa
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A few issues

Any suggestions and/or help would be greatly appreciated.

97 F250 7.3 PSD, 4x4, Auto, 170,k miles

Mods:

3" Down Pipe
4" MBRP Exhaust
S&B Intake

I bought the truck a few months ago, a few weeks after my OD light started flashing. This was after we got a ton of rain, I figured it was something electrical. I changed the speed sensor on the rear end and the light went off and has not returned. Since I have owned her, I have been getting in the area of 14-15 mpg. Didn't seem right to me, but from reading other posts and talking to people I know in the area it seemed to be the norm with winter diesel.

The issue:

The trans has always seemed to have a soft shift into 3rd and have some issues with TC lock up and gear hang up. I ordered a solenoid pack and connector and will be putting that in this week. My issue is, the truck seems to be extremely under powered. I am not completely convinced the tranny could contribute to this kind of power loss.

Just for some more info... The fuel filter was just changed along with cleaning the air filter. Oil will be done this week when I change the trans fluid. New glow plugs and relay. Also, the truck does not have a chip.

Thanks in advance,
Brian

Last edited by bleheny; 03-07-2011 at 08:42 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-08-2011, 03:02 PM
Member
 

Join Date: Feb 2011
Location: Aliquippa
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
UPDATE...

It was the solenoid pack, now she's balls to the wall.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors