Rough Idle, Falls On face sometimes after clutch is depressed - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-10-2007, 06:52 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Wisconsin
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rough Idle, Falls On face sometimes after clutch is depressed

My truck will sometimes idle wierd, what it will do is idle fine for a while then every now and then it will kinda jump just a little bit not much maybe 50 or so RPM just bearly noticable on the Tach and when it does this it almost seems like it runs better. Also sometimes when i depress the clutch fast the motor will kinda fall on its face, it wont stall, just kinda struggle for a little bit then come back out of it after a couple seconds.
So far i have a new 17* HPOP and IPR
also new CPS

Im starting to think i have a faulty injector, but i did a Contribution Test a while back and everything passed, got two codes from it though P0196 and P0236

Truck will be outa commision till Prolly this weekend, Dual Mass Clutch finally went, ill be tearing it down tonight and tomorrow, then friday new South Bend Clutch should be in. I would still like to get these last few kinks worked out though, it those little things that are hard to find that just drive you nuts

thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-11-2007, 04:07 AM
Premium Member
 

Join Date: Feb 2006
Location: Ft Worth
Posts: 1,210
Thanks: 0
Thanked 8 Times in 5 Posts
Feedback Score: 3 reviews
You will probably find that the problem is gone when your new clutch is in. Sounds like a classic problem with the stock dual mass.
Reply With Quote Quick reply to this message
  #3  
Old 07-15-2007, 05:17 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Wisconsin
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
replaced the dual mass with south bend solid con-o both problems are still there, think maybe it is a faulty injector?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors