strange brake problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-08-2011, 11:47 AM Thread Starter
Compression Ignition Addict
dr.deere's Avatar
Join Date: Jan 2011
Location: jamestown, nd
Posts: 749
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
strange brake problem

hi everybody. i have a 94 f-250 4x4. with cruise and a 5 speed manual. the brakes have felt not right since i bought this pickup a couple months ago. they feel soft and if i push the pedal hard it fades to the floor. so i checked the basics fluid level, leaks brake adjustment on rears. everything looked good so i put a new mastercylinder on it today. bled brakes at all 4 corners starting at right rear and working towards left front. no air from any corners pedal feels great. start pickup and back to same problem. so my question is do i have a bad brake booster. its not what i would expect from a bad booster but i'm at a loss now.
dr.deere is offline  
Sponsored Links
post #2 of 2 Old 01-08-2011, 12:57 PM Fanatic
Join Date: Dec 2010
Location: nw corner of wash. state
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
You might try checking the vacuum pump mounted on the driver's side front of the motor.These have a habit of slowly going bad over the years.If you aren't noticing any fluid leaks,the pump might be your problem.Good luck!
garyeco is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome