Hood jammed - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-13-2010, 07:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to delorean623
Hood jammed

I've got a '97 OBS PSD and my hood is jammed...well sort of open and sort of closed. The latch is engaged, but the piece that is hooked up to the hood release in the cab is engaged but not latched on to the hood. Hopefully the picture will more accurately describe what's happening.

I had the hood open fully for a few minutes then let it rest at the bottom of travel (but without engaging the latch) for about 4 hours. When I went to shut the hood, it fought back as shown in the picture.

Thoughts?



2002 Ford F-250 Lariat SuperCab long bed 7.3L PSD. DP F5, aFe Magnum Force State 2 Intake with Pro-Dry S MEdia, Magnaflow 4" turbo-back stainless exhaust, Alpine iDA-X100, Pioneer speakers, Kenwood KAC-8104D amp, Sony Low Profile Sealed Subwoofer System (1200w), Toyo Open Country A/T 285/75-16 tires, Randy Ellis Designs light bar, Fumoto quick drain valve, CCV Mod, 2005-07 lower dash with upfitter switches.
delorean623 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-14-2010, 08:53 AM
Compression Ignition Addict
 
Aaron Berk's Avatar
 
Join Date: Jul 2009
Location: Wilmington Island, GA
Posts: 739
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Can't see any pics

97 F250 ext cab lwb 4x2
AirDog2 and FASS HD (it's a WVO RR setup)
Simple Centrifuge filtering method
203 degree Mod, DIY homegrown intake, CCV mod, battery relocation,
215amp Ambulance Alt.
EBPV gut, Pedestal gut & cut
Diamond Eye 4" (3" dp) turbo back straight pipe
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
no kitty, no muffler
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Aaron Berk is offline  
post #3 of 5 Old 11-14-2010, 11:40 AM
Compression Ignition Addict
 
Join Date: Jan 2010
Location: Western Montana
Posts: 288
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Not sure. Will it close the rest of the way? If so then the release should work, right?

Brian

'96 F250 SC, 7.3, 4x4, E40D, and it's red... and white.
retmotor is offline  
post #4 of 5 Old 11-14-2010, 06:46 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to delorean623
It wouldn't close or open any more than that. The C piece was jammed, the latch was jammed, I wound up having to (while scraping my arms on radiator fins) get a 10mm in there through the grille to remove the latch assembly. The only thing that I could figure was that the alignment got tweaked and that's what caused the problem. I reinstalled it, realigned it, and it seems to be working great now. Just a random fluke, I guess.

2002 Ford F-250 Lariat SuperCab long bed 7.3L PSD. DP F5, aFe Magnum Force State 2 Intake with Pro-Dry S MEdia, Magnaflow 4" turbo-back stainless exhaust, Alpine iDA-X100, Pioneer speakers, Kenwood KAC-8104D amp, Sony Low Profile Sealed Subwoofer System (1200w), Toyo Open Country A/T 285/75-16 tires, Randy Ellis Designs light bar, Fumoto quick drain valve, CCV Mod, 2005-07 lower dash with upfitter switches.
delorean623 is offline  
post #5 of 5 Old 11-14-2010, 09:48 PM
Compression Ignition Addict
 
Join Date: Jan 2010
Location: Western Montana
Posts: 288
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Weird. Well glad you got it fixed. Should it happen again, the only other idea I can think of would be to manipulate the latch with a tool (screwdriver?) while another person is pulling the hood release latch. Don't know if that'd work or not...

Brian

'96 F250 SC, 7.3, 4x4, E40D, and it's red... and white.
retmotor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome