possible vacuum pump failure, need opinions - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-20-2010, 05:30 PM Thread Starter
Powerstroke.org Fanatic
Twisty's Avatar
Join Date: Nov 2009
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
possible vacuum pump failure, need opinions

If I step on the brake coming to a stop sign, my brakes work fine. If I release the pedal and step again, the pedal gets harder (like the truck is off) and the brake light comes on. Once I drive away, after about 5-10 seconds, the brake light will go off and I will have brakes again (until I stop or pump the brakes).

If I park the truck (with vacuum pressure in the booster) and let it sit for 30 mins, I can step on the brakes (truck off) and they are normal (granted the pedal firms after 1-2 pumps, but that's normal for a non-running truck). I do not think I have a leak.

I took the vacuum cleaner out of the house, and put it on the booster. The booster worked normal and the brakes felt fine. This leads me to believe that its not the booster.

So, what do you think? Booster or pump? I need to tow my Jeep this weekend and need to get it fixed!!! I already have a new vacuum pump, but don't have enough money to throw around trying to get the right part. My suspicion is the pump, but I want another opinion. I will be diving into this tomorrow so I need your input!!!

1996 F350 CCLB: ZF5 with Valair clutch, Rosewood stage 1 injectors, T500 HPOP, PHP tunes, Tymar intake, 5" straight exhaust.
Twisty is offline  
Sponsored Links
post #2 of 2 Old 11-30-2010, 05:02 AM
Powerstroke.org Fanatic
bighunter's Avatar
Join Date: Feb 2006
Location: arizona
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I Know its two months too late but I have the same problem. so heres a bump.

96 F250 XLT 4x4 crew cab SB PSD, 4.10 gears,5 speed manuel tranny, 4" lift, 35's,Autometer gauges, 3" down pipe, 4" Magnaflow exhaust with gutted cat, Tymar style intake, Banks intercooler, quick spin turbo, 6 pos DP-Tuner .
bighunter is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome