97 E350 7.3 IDM Relay Clicking...Bad PCM?? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-19-2010, 04:49 PM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 E350 7.3 IDM Relay Clicking...Bad PCM??

Turn the key on and the IDM relay just clicks very rapidly, on the PCM relay for post 30 and 85 i have 12 volts, at 87 have 6 volts and 86 has nothing. On the IDM relay i have 12 volts at 30 but only 6 volts at 85 and nothing at 87 and 86, Ive pulled the fuse box apart and all the wires look good, cleaned the batteries and checked the grounds and all looks good. Also took the PCM connector apart and all the wires look good, and tried a known good IDM with the same results. Im leaning towards a bad PCM but need more info and some help before i drop the cash on a new one. Thanks
HotRodV6 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome