Speedometer/Odometer Dead - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-19-2010, 02:03 PM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Speedometer/Odometer Dead

I drove the truck to work without issue (The speedo did bounce prior) and when I went to lunch my speedometer and odometer were dead. There is nothing going to the LCD for the Odometer and the speedo isn't moving at all. Pulled the fuse which looked fine, so I am assuming my speedo is shot, is there anything else to look for prior to buying a new/used speedometer?

sfzobie is offline  
post #2 of 2 Old 10-19-2010, 02:20 PM
Powerstroke.org Rookie
Join Date: Feb 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
check the speed sensor located on the rear end. mine went out a couple of years ago, its an easy fix.
wcastle is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome