Turn signals not working - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-05-2010, 12:15 PM
Member
 

Join Date: Aug 2010
Location: Southern New Jersey
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Turn signals not working

turn signals worked fine all summer, but now with days that are 50-65 and so far rainy they dont work. hazard lights work fine and they light up when the running lights are on. and theyll come on when the turn signal handle is held down over a few minutes. any suggstions?
thanks
steve
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-05-2010, 12:59 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unplug the flasher and check if you are getting voltage at the socket with a test light or voltmeter when you use the turn signal handle. If not, it's probably in the turn signal handle assembly. If yes, replace flasher or it's a wiring problem between the flasher and the bulbs.
Reply With Quote Quick reply to this message
  #3  
Old 10-05-2010, 01:26 PM
Member
 

Join Date: Aug 2010
Location: Southern New Jersey
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks man, its only sometimes it doesnt work. but thanks ill check it this week.
Reply With Quote Quick reply to this message
  #4  
Old 10-23-2010, 04:31 PM
Powerstroke.org Rookie
 

Join Date: Sep 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the exact same issue that just started. On 2005 I think the procedure is to replace the turn signal arm. Still researching.
Reply With Quote Quick reply to this message
  #5  
Old 10-28-2010, 10:56 AM
Member
 

Join Date: Aug 2010
Location: Southern New Jersey
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i just replaced the flasher and she works
Reply With Quote Quick reply to this message
  #6  
Old 11-01-2010, 11:17 AM
Powerstroke.org Rookie
 

Join Date: Nov 2010
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to High7echRedneck
Also if it happens again check the contacts on the bulb and housing, sometimes corrosion builds up and makes them work intermittently as you described.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors