My starter wont shut off! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-04-2010, 01:11 PM Thread Starter
Member
 
Join Date: Mar 2010
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My starter wont shut off!

Jumped in it this morning (about 28* out) went to start it and the starter just kept turning over. Truck didn't start, usually takes a few tries on cold mornings. By the time I got my terminals off the batteries were about done.

Replaced the starter solenoid.
back woods is offline  
post #2 of 5 Old 10-04-2010, 01:21 PM
Compression Ignition Addict
 
superduty4x4's Avatar
 
Join Date: Nov 2007
Posts: 2,355
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did it solve the problem???

97 F350 CCLB 4x4 PSD
superduty4x4 is offline  
post #3 of 5 Old 10-04-2010, 01:30 PM Thread Starter
Member
 
Join Date: Mar 2010
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry, I should have made my post more detailed.

It did not solve the problem. Truck is a 95 F250 ECLB.
back woods is offline  
post #4 of 5 Old 10-04-2010, 01:47 PM
Compression Ignition Addict
 
superduty4x4's Avatar
 
Join Date: Nov 2007
Posts: 2,355
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Could be a bad relay, or possibly a problem with the ignition tumbler... but other than that I'm not much help.

97 F350 CCLB 4x4 PSD
superduty4x4 is offline  
post #5 of 5 Old 10-04-2010, 01:54 PM Thread Starter
Member
 
Join Date: Mar 2010
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The tumbler slide in the column broke a while ago, i can start the truck with the key and i use toggles for all the electrical. Its never done this before and I lubed everything in the column.
back woods is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome