95 idles but dies driving?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-08-2010, 08:48 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 95 idles but dies driving??

Buddy has a 95 he purchased non running. The initial problem was the CPS. Got the truck running and let it idle for about 20 min with no problems. While its idling you could goose it some and it would act normal. As soon as it hit the road and started opening up some it died and would not fire back up. Towed it back to the house and came back to it the next morning. Fired right up and did the same thing when trying to drive it. Fuel pressure is good, oil pressure is good (going only off the in cab cluster). Any ideas? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-08-2010, 08:49 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Are these FPR's mechanical or electrical? Ill look in a bit, just stuck in office right now
Reply With Quote Quick reply to this message
  #3  
Old 09-09-2010, 06:13 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump ttt......
Reply With Quote Quick reply to this message
  #4  
Old 09-10-2010, 05:26 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump for the weekend
Reply With Quote Quick reply to this message
  #5  
Old 09-11-2010, 05:09 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,350
Thanks: 0
Thanked 3 Times in 1 Post
Feedback Score: 2 reviews
hey man sounds like a CPS... had the same problem
Reply With Quote Quick reply to this message
  #6  
Old 09-12-2010, 01:37 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is it common to buy a new CPS and it be bad then? We replaced the CPS first thing.
Reply With Quote Quick reply to this message
  #7  
Old 09-12-2010, 03:01 PM
Rangers Lead The Way!
 

Join Date: Nov 2009
Posts: 11,400
Thanks: 0
Thanked 11 Times in 9 Posts
Feedback Score: 2 reviews
yeah its happened before where the CPS was junk when someone got them. But my question is now. when you let it idle does it warm up? when you take it out on the road does it finally get warmed up then die out?? Could be IPR o rings if thats the case
Reply With Quote Quick reply to this message
  #8  
Old 10-18-2010, 05:57 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok guys update, and im even more confused. Another brand new CPS, new IPR, new HPOP (pressure is fine), contribution test is in range. We pulled the bed to follow all fuel lines, etc. Nothing is rotted and were getting fuel to the bowl no problem. Still same problem. Try to drive it and as soon as it starts warming up a little it dies, BUT if we unplug the battery for about 30 sec it will fire right back up no matter the temp.????? Obviously something electrical. Were at a total loss and my buddy is balls deep into it with cash by now lol. Any ideas?
Reply With Quote Quick reply to this message
  #9  
Old 10-18-2010, 03:01 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump for the night
Reply With Quote Quick reply to this message
  #10  
Old 10-21-2010, 03:44 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump before work
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors