95 PSD goes into safe mode when pulling a load, or climbing a hill! help!! - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-22-2010, 02:34 PM Thread Starter
Powerstroke.org Rookie
 
1995 FORD POWERSTROKE (:'s Avatar
 
Join Date: Dec 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation 95 PSD goes into safe mode when pulling a load, or climbing a hill! help!!

so my 95 PSD goes into safe mode when pulling a load, or climbing a hill! help!!
my guess is its either a bad sensor or not enough fuel...I need some help to get this fixed its complitley stock with 250XXX miles, oh with jsut a K&N on it.

any help will be awsome.

1995 F350 xlt powerstroke diesel crew cab long bed
1984 mercedes 300sd green 4 door automatic
Lots of fun toys Like Raptors

Music is the beat of my heart "and truck"


1995 FORD POWERSTROKE (: is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome