reinstalling injectors? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-19-2010, 08:02 PM
Member
 

Join Date: Aug 2010
Location: phoenix
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
reinstalling injectors?

When reinstalling injectors on a 97 7.3 OBS is there a different part # for the 8th injector or does it not matter?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-19-2010, 08:03 PM
a truck
 

Join Date: Nov 2007
Location: Lima, OH
Posts: 13,142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Doesnt matter, just throw them back in there
Reply With Quote Quick reply to this message
  #3  
Old 08-19-2010, 08:06 PM
Member
 

Join Date: Aug 2010
Location: phoenix
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks......
Reply With Quote Quick reply to this message
  #4  
Old 08-19-2010, 08:10 PM
a truck
 

Join Date: Nov 2007
Location: Lima, OH
Posts: 13,142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No problem, if you need any tips on putting them back in, I have a write up in the tech section
Reply With Quote Quick reply to this message
  #5  
Old 08-19-2010, 08:15 PM
Member
 

Join Date: Aug 2010
Location: phoenix
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I have allready reinstalled them. not to bad considering all i have is a giant welt on my stomach from the hood latch . i still need to figure out why it constantly blows white smoke and has a slight miss when idling, and has no power when i drive it, im completly stumped.
Reply With Quote Quick reply to this message
  #6  
Old 08-19-2010, 08:17 PM
a truck
 

Join Date: Nov 2007
Location: Lima, OH
Posts: 13,142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How long or how far have you driven it since you installed the injectors, whenever I do injectors I drive at least 50 miles after to work all the air out
Reply With Quote Quick reply to this message
  #7  
Old 08-19-2010, 08:30 PM
Member
 

Join Date: Aug 2010
Location: phoenix
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I think ive drivin it maybe 2 miles, i just have this feeling deep down that there is still something wrong. when i say it blows smoke it covers a 1 mile radius when i get on it but it has no power and the boost gauge reeds 10 psi max, i can smell pure unburnt fuel at idle from the exhaust and it just smokes constantly. when we did a diagnostic on it we were able to monitor everything and the only failure was the injectors they were in bad condition, after taking them in for a rebuild i was notified that they were hybrid and that bumped up the bill alot. i know its chipped but i have no idea whats in it and im thinking the tune is not correct, i think i need to pull the IDM and see if theres a chip in there. right now im at a loss. also my buddy said it has a larger pump and said the fuel pressure is correct but im not sure what it was reading, ive also replaced the crank sensor since then.
Reply With Quote Quick reply to this message
  #8  
Old 08-20-2010, 07:53 PM
Banned
 

Join Date: Oct 2009
Location: North Port
Posts: 920
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
Im not sure you can chip an IDM. You get air stuck in them and you gotta run them till the air is pushed out. Did you check the oil? And every time i do injectors the exhaust gets coated with oil and takes a while to burn it off.
Reply With Quote Quick reply to this message
  #9  
Old 08-20-2010, 08:27 PM
Banned
 

Join Date: Mar 2010
Location: alabamer
Posts: 1,078
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to harley1rocker Send a message via Skype™ to harley1rocker
Quote:
Originally Posted by DieselEater View Post
I think ive drivin it maybe 2 miles, i just have this feeling deep down that there is still something wrong. when i say it blows smoke it covers a 1 mile radius when i get on it but it has no power and the boost gauge reeds 10 psi max, i can smell pure unburnt fuel at idle from the exhaust and it just smokes constantly. when we did a diagnostic on it we were able to monitor everything and the only failure was the injectors they were in bad condition, after taking them in for a rebuild i was notified that they were hybrid and that bumped up the bill alot. i know its chipped but i have no idea whats in it and im thinking the tune is not correct, i think i need to pull the IDM and see if theres a chip in there. right now im at a loss. also my buddy said it has a larger pump and said the fuel pressure is correct but im not sure what it was reading, ive also replaced the crank sensor since then.
your spot on with that "gut feeling ".hate to be the bearer of bad news,but it sounds like you have worn/cracked rings...how many miles??? either that or your heads need reworkin,valves,cups and all.i got mine done for 400 dollars.i thought mine was just heads,nope,i got the heads off thinkin i was gonna get a way with just that...looked at the pistons and num 5 was chewed all to hell and back by a peice of broken ring...its fun when you get it out though...its really very simple..the key is to be very very orginized
Reply With Quote Quick reply to this message
  #10  
Old 08-22-2010, 03:28 PM
Member
 

Join Date: Aug 2010
Location: phoenix
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 96F350KID View Post
Im not sure you can chip an IDM. You get air stuck in them and you gotta run them till the air is pushed out. Did you check the oil? And every time i do injectors the exhaust gets coated with oil and takes a while to burn it off.
LOL! i meant to say PCM, im still geting used to diesel talk. im still not quite sure whats wrong with the truck. im going to post a video here in a minuite, thanks for all the help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors