AC Cycle switch failure - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-24-2007, 06:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2006
Location: Lexington, KY
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
AC Cycle switch failure

My 2003 is on it's 4th AC cycle switch, needing a 5th installed. Has anyone else had issues with their AC systems ?
Seems every spring , I switch to AC and warm air comes out.
Thanks !
UniBrow is offline  
post #2 of 2 Old 05-24-2007, 07:04 AM
Compression Ignition Addict
 
Justinlw's Avatar
 
Join Date: Feb 2007
Posts: 1,199
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Feedback Score: 0 reviews
Send a message via MSN to Justinlw
On my dad's it was the pigtail that plugs into the clutch on the compressor. We soldered in a new one and had no more problems. I've heard this in more than one case. His is a '95.

2010 F250 Lariat 6.4l
SCT 3015R/Gearhead Tuned, Edge Insight CTS,
FloPro DPF Pipe, EGR Delete/Elbow
Justinlw is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome