Superchip 1705 is a piece of S*** - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2008, 05:39 PM
Electrical Ogre
 

Join Date: Aug 2007
Location: Calgary, Alberta
Posts: 11,490
Thanks: 29
Thanked 47 Times in 44 Posts
Feedback Score: 1 reviews
Superchip 1705 is a piece of S***

I'm ranting because I have friggin had it up to here. I bought the tuner last year before I started to learn about custom chips like Tony's. Here's the deal: Last year, I installed the "high peformance tune" when I bought the unit. A month or so later, I had to pull a trailer, so I wanted to bump the programming back a bit. When I tried to reprogram, I got the message "Wrong vehicle" or something like that. After calling Superchips long distance to get a RA number, shipping off the tuner, waiting a month, and shelling out $80.00 for both ways shipping and UPS customs (which is bull**** for a warranty item,) I got the tuner back. With the tuner back, I plugged it in, it re-installed the stock tune, then I installed the "tow performance tune." Now that the weather is getting better, and I haven't had a chance to put in my Wildman chip and stage II squiters, I though I'd go back to the performance tune. When I attempted to re-tune the truck, I am getting the wrong vehicle message again. This is crap, I haven't changed a damn thing on the truck since the tune was put in, and I'll be damned if I am gonna spend another $80.00 on this piece of crap.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-26-2008, 05:59 PM
Compression Ignition Addict
 
Join Date: Feb 2008
Location: nampa idaho
Posts: 481
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to mikeslegers
ive got a 1704 superchip, the previous owner installed it before i bought the truck from him. I am getting rid of it because its a piece. switching to an sct. I wouldn't doubt it that your superchip is having problems, their just not good products in my opinion.
Reply With Quote Quick reply to this message
  #3  
Old 02-26-2008, 06:05 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
As soon as you get the issues figured out drive down the road and throw that piece of crap out the window.
Reply With Quote Quick reply to this message
  #4  
Old 02-27-2008, 05:40 PM
Electrical Ogre
 

Join Date: Aug 2007
Location: Calgary, Alberta
Posts: 11,490
Thanks: 29
Thanked 47 Times in 44 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by 2005F250 View Post
As soon as you get the issues figured out drive down the road and throw that piece of crap out the window.
Well, you missed the part about stopping, reversing, and driving back and forth repeatedly over the dang thing.

E-mailed superchips today, on the "contact form" I listed the issue and that it's happened again, and crammed in the previous RA# at them. I will be so damn happy when I have time to do my injectors and throw in Tony's chip
Reply With Quote Quick reply to this message
  #5  
Old 02-28-2008, 02:07 PM
Too cool for school


 

Join Date: Jan 2008
Posts: 9,889
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 3 reviews
Send a message via AIM to taylorking Send a message via Yahoo to taylorking
WOW the exact same thing happened to my dad!

We had the MaxMicro tuner (1705?) and out it on right before we went on vacation to Daytona Beach (from charlotte NC). We set it on high performance and set sail....Well when we got there we calculated gas mileage and decided to switch it down a notch do perf. tow.....

Well didnt go as planned. We got the error message that said it was the wrong vin on the vehicle (wrong vehicle). Called superchips and they said the truck must have had a chip on the computer from the previous owner. So here me and my dad are out in 100* weather taking the computer out, and burning up. (Those things are a pain in the a--).

As we figured there was no chip there. Superchips told us we would have to get it reflashed by a dealer. Of course we were like 8 hours from home...My dad asks "Just by chance where are you located?" Near Orlando, so we set off about 70mi. to some little city near there. Got there and the place is pretty tiny.

They took our tuner and "Unlocked" it or whatever. Then we got a new computer, stuck it in and set it on perf. tow.

Had the exact same problem one other time and had to send the tuner back!




So now we have a spare computer locked on perf. tow (in my truck) and another one in my dad's F350 lol!
Reply With Quote Quick reply to this message
  #6  
Old 02-28-2008, 02:12 PM
BIG TRUCK, SMALL DRIVER
 

Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I never had any problems with my 1705. It is a '01 model and only has two tunes. It has been ran on about 5 different trucks. I got a Excal2 for the wife's Stang and after returning to stock, I can't load a new tune or even read codes. It's a piece. At least you have a Wildman chip to look forward to.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:03 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors