SBC clatter - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2010, 03:32 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SBC clatter

I have a south bend clutch and flywheel in my truck and from day one have had a super loud clatter from the clutch while either lugging in a gear some in low RPM or in nuetral with the clutch released. They said that you will experience some clatter due to the upgraded springs but this is LOUD. My buddy just put the same clutch and flywheel in his 96 and you cant hear a thing. Dont take this the wrong way- I am NOT blaming south bend for this issue and have been very happy with the performance of the clutch. I am just curious as to what would cause a clutch to create this much noise? Has anybody else experienced anything like this? FYI I now have over 19,000 miles on the clutch and it has not changed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-14-2010, 03:53 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Biggest thing is I wanna know if I should be concerned as I get into higher mileage...
Reply With Quote Quick reply to this message
  #3  
Old 03-15-2010, 02:54 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump......
Reply With Quote Quick reply to this message
  #4  
Old 03-16-2010, 06:24 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
nobody else has had this problem??
Reply With Quote Quick reply to this message
  #5  
Old 03-20-2010, 01:48 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump again. Nobody?
Reply With Quote Quick reply to this message
  #6  
Old 03-20-2010, 01:53 PM
Compression Ignition Addict
 

Join Date: Mar 2010
Location: Missouri
Posts: 977
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have not had one, but i have heard of guys saying theirs rattle, but if it is super loud i would be complaining too...
Reply With Quote Quick reply to this message
  #7  
Old 03-20-2010, 02:07 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lol well at least im not the only one
Reply With Quote Quick reply to this message
  #8  
Old 03-25-2010, 05:06 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know im having a convo with myself but yet another bump.....
Reply With Quote Quick reply to this message
  #9  
Old 03-25-2010, 06:00 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Aurora, IL
Posts: 555
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have a SBC with about 500 miles on it. i have the 375 HP clutch, and i dont notice any chatter. there is a little bit of grabiness and i feel a little somthing in the pedal sometimes in reverse....but other then that...its a really nice quiet clutch
Reply With Quote Quick reply to this message
  #10  
Old 03-26-2010, 02:55 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Rootstown, OH
Posts: 1,364
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Nitro41 View Post
i have a SBC with about 500 miles on it. i have the 375 HP clutch, and i dont notice any chatter. there is a little bit of grabiness and i feel a little somthing in the pedal sometimes in reverse....but other then that...its a really nice quiet clutch
So it must be a defect somehwere. That seems to be what everybody has said....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors