Speedometer not working??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-11-2013, 11:34 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2012
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Speedometer not working???

I took the gauge out of my 95 and cleaned it did not spray it or anything I put it back it and everything works except mt speedomoter and mi ticker. Anyone know what it could be?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-11-2013, 02:50 PM
DERAIL MOD!!!


 

Join Date: May 2011
Location: Canton and kennesaw
Posts: 20,894
Thanks: 10
Thanked 117 Times in 109 Posts
Feedback Score: 4 reviews
Check the fuses? Hooked all 3 plugs back in? Knick the plastic/circuit grid thing anywhere? I popped a fuse once and took me a few days to find
Reply With Quote Quick reply to this message
  #3  
Old 03-11-2013, 02:55 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2012
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Re: Speedometer not working???

Yea I checked the cluster fuse, unless there is just one for the speed only its good, and I checked the board and it looks good as new, I done it all in the house so I made sure I dident break it and sure eoungh I did anyways lol the bad thing is I don't remember my rpms at speed, and idk my gear ratio either

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 03-12-2013, 11:52 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Gilbert PA
Posts: 2,021
Thanks: 3
Thanked 17 Times in 16 Posts
Feedback Score: 0 reviews
You don't have one of the 3 plugs in all the way
Reply With Quote Quick reply to this message
  #5  
Old 03-12-2013, 01:38 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2012
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Re: Speedometer not working???

I was blowing a fuse and side.t realise it, it would pop a fuse unless it was bolted it it works fine now
Reply With Quote Quick reply to this message
  #6  
Old 03-15-2013, 11:58 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2012
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Speedometer not working???

It blew a fuse today again I may have to pull it apart agian


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors