sounds like an injector - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2014, 03:46 AM
Member
 

Join Date: Sep 2007
Location: Middleburg, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like an ICP sensor

a few seconds after i start the truck up, it sounds like an injector went bad, motor and truck shakes and check engine light kicks on, but no smoke out of the stacks. when i give it fuel, it still does same thing. when i put it in drive, i can drive but hesitates a little. then after about 45 seconds the truck goes back to normal, meaning it goes to normal idle and the check engine light turns out.

i dont have a scanner to check codes. i can go to Advance Auto to see what their scanner says but im just getting a feeler out there to see if you guys had that problem.

At first i thought it may have been a little bit of jell, but it does it when i start it up, even when the motor is warm. Filter is not jelled, filter is clean

Any thoughts?????? and it does not do it while im driving. I could drive cross country with it. just cant shut it down, or it will do it.

Last edited by farmallcrew; 01-30-2014 at 04:55 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2014, 10:27 AM
Member
 

Join Date: Sep 2007
Location: Middleburg, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
found out what the issue is.

Rough Idle check engine light on

there is oil in the sensor and doesn't stop with the rough idle. Cheapest place i found FORD OEM part is ebay. It will be soon be purchased.
Reply With Quote Quick reply to this message
  #3  
Old 01-30-2014, 04:54 AM
Member
 

Join Date: Sep 2007
Location: Middleburg, PA
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Put a used ICP sensor in, and still does it. What else could it be?????
Reply With Quote Quick reply to this message
  #4  
Old 01-30-2014, 07:38 AM
Hee Hee, he's doing it...
 

Join Date: Oct 2011
Location: Pasadena, CA
Posts: 5,490
Thanks: 44
Thanked 85 Times in 80 Posts
Feedback Score: 0 reviews
Fuel issues and injector issues generally present with white smoke. Pull the ICP connector off and start the truck. Does it still shake? Pull the IPR out of the HPOP (the tin nut on the end of the IPR is tight correct?) clean the IPR and reinstall. test again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors