Dead pedal from 50-100% - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-26-2013, 04:01 PM
Compression Ignition Addict
 

Join Date: Oct 2012
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dead pedal from 50-100%

As title states my truck is becoming a dog, worse when warm. Pedal seems completely dead from half to full throttle. No change in engine reponse, noise, rpms, nothing ??????? When cold its had fairly decent power but ill have to get on it when cold here maybe tom and check on that.

Bad TPS???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-26-2013, 06:44 PM
Can you hear the derail??

 

Join Date: May 2011
Location: Canton and kennesaw
Posts: 20,489
Thanks: 6
Thanked 104 Times in 97 Posts
Feedback Score: 4 reviews
Sounds like you found it,
Reply With Quote Quick reply to this message
  #3  
Old 12-26-2013, 06:57 PM
Compression Ignition Addict
 

Join Date: Oct 2012
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Serious??? Maybe that simple huh?

Any other tests i should run well of course i could hookup meter and wires and go through all that but any symptoms you guys have off the top of your head when tps goes bad??
Reply With Quote Quick reply to this message
  #4  
Old 12-26-2013, 07:07 PM
Can you hear the derail??

 

Join Date: May 2011
Location: Canton and kennesaw
Posts: 20,489
Thanks: 6
Thanked 104 Times in 97 Posts
Feedback Score: 4 reviews
I turned my truck off and back on my dead pedal worked fine again, but also another time removed the chip it worked fine too
Reply With Quote Quick reply to this message
  #5  
Old 12-27-2013, 04:58 PM
the baconator
 

Join Date: May 2009
Location: Easton MD 21601
Posts: 11,272
Thanks: 6
Thanked 48 Times in 48 Posts
Feedback Score: 1 reviews
the lack of power when warm says to me a problem with the HPO as it warms it thins and no longer provides the pressure you need. as if there is a cut/tear in the IPR allowing to much oil to flow past
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:53 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors