OBS belt driven air problem - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-04-2013, 05:01 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
OBS belt driven air problem

Hey guys, I am working on an underhood pressure lubed truck (semi) compressor project and have an unexpected issues. I installed a tu-flo compressor on the passenger side of the engine compartment with a shoe horn and a creative bracket fab. The compressor is driven off of a pulley i welded to the alternator pulley. My lube comes from the filter block and runs in 1/4 copper tube to the compressor, the return is 3/8 gravity flow into the passenger side valve cover. The issue is the compressor crankcase fills full of oil and locks it up. The setup ran fine for a few weeks then seemed to flop all of a sudden. The compressor unloaded at 150psi and I have a 10 gal tank under the bed (stakebody) I have checked for obstructions in the return hose and taken the compressor apart and looked for blockage, none found. Is this a crank ventilation problem? I fell in love with it in the short time i had it, and want it back. I promise pics and details if/when it works. Thanks, Chris

'97 Superduty from ford. Someone else added 14' stakebody and liftgate. I added onboard engine driven air, 2000 watt inverter, remote keyless, cruise, couple toolboxes,lights, backup camera, blabla
U477 is offline  
post #2 of 2 Old 06-04-2013, 05:12 PM
Unpremium Member
gaspipe's Avatar
Join Date: Dec 2011
Location: Hootersville, TN
Posts: 700
Thanks: 3
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like you need a larger oil return to the 7.3, and perhaps use a CCV on the passenger valve cover so the oil can gravity flow. Otherwise, you'll need a pump.

'95 F250 4x4 ECLB 295k - ZF5, Southbend, 4.10, van pedestal, EBPV & CCV delete, 1.0 ex housing, 3" DP, 4" exhaust, BFAF, 140v IDM, MagHytec diff cover, HD front springs, 16x8 alloys
'95 F-Superduty 4x2 CM 12' Flatbed 33k - E4OD, 5.13, Banks intercooler, van pedestal, EBPV & CCV delete, 1.0 ex housing, 3" DP, 4" exhaust, BFAF, PHP tunes, 6.0 fan, 140v IDM, TruCool, MagHytec diff/pan, Dieselsite external trans filter, Autometer gauges, 180w LED light bar
gaspipe is offline  

on board air

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome