help on a 1995 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-27-2008, 06:29 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: hermiston,oregon
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
help on a 1995

just bought a 1995 f350 ps standard cab 4x4 193000 when i started it up white smoke was present small amount,at idle it was there but not much. the guy said the truck never gets warm? new injectors, water pump,thermostat.you guys got any ideas as whats going on. no mods to the truck ever bone stock. any ideas would be great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-27-2008, 06:48 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: hermiston,oregon
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no body out there tonite?
Reply With Quote Quick reply to this message
  #3  
Old 02-27-2008, 06:54 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
never gets warm...or never gets warm at idle??
Reply With Quote Quick reply to this message
  #4  
Old 02-27-2008, 07:06 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Location: Padua IL
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Never gets warm can cover a lot of ground.. never gets warm as in the guage doesn't move? Never gets warm as in no heat out of the heater? Radiator cold after running for a while? Runs a little "off" like it's freshly started?
Reply With Quote Quick reply to this message
  #5  
Old 02-27-2008, 07:07 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
are you SURE the tstat isnt stuck open??
Reply With Quote Quick reply to this message
  #6  
Old 02-27-2008, 07:12 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: miami fl
Posts: 507
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to FiberglassEater
my 97 always smokes white in the morning .... but then again i think i got some bad glowplugs.....
Reply With Quote Quick reply to this message
  #7  
Old 02-27-2008, 07:17 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Eugene Oregon
Posts: 503
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like a stuck thermo but my truck smokes a little in the morning
Reply With Quote Quick reply to this message
  #8  
Old 02-28-2008, 05:10 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: hermiston,oregon
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Marc View Post
never gets warm...or never gets warm at idle??
60 degrees outside ran for 15 mins just barely off cold.
Reply With Quote Quick reply to this message
  #9  
Old 02-28-2008, 05:11 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: hermiston,oregon
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by MarlandS View Post
Never gets warm can cover a lot of ground.. never gets warm as in the guage doesn't move? Never gets warm as in no heat out of the heater? Radiator cold after running for a while? Runs a little "off" like it's freshly started?
barely moves off cold on gauge and there is hot air from heater.has a good idle
Reply With Quote Quick reply to this message
  #10  
Old 02-28-2008, 05:15 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: hermiston,oregon
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Marc View Post
never gets warm...or never gets warm at idle??
didnt get warm at idle but hot air coming from heater vents
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors