Ignition in column issue - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-23-2013, 07:18 PM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ignition in column issue

Hello,
My wife washed and waxed my 96 today and when she went to put the truck away she turned the key waited for glow plugs to cycle then turned key and nothing. She turned the key back and it was loose. Now when the key is turned off and out of ignition the accessories are still on. I pulled out the cylinder and it seems to be functioning fine although I don't really know what to look at. The piece that it turns in the column however spins circles which doesn't seem right. Any help would be great! Thanks again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-24-2013, 05:06 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2010
Location: Pennsylvania
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you say you pulled the cylinder out that the key goes in? because theres supposed to be a pin looking thing that keeps that from moving until you turn the key forward and push the pin up with a screwdriver. take some pictures and ill be able to help you ive done many steering columns for these trucks
Reply With Quote Quick reply to this message
  #3  
Old 04-24-2013, 06:26 PM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply. I have since concluded that it is the actuator rod. The key moves the top rod but not the part that attaches to the ignition module. I got it apart and can now at least move the truck! From the research that I have done I need to pull the whole steering column to replace. Is that correct? Should I replace both the upper and lower rods? I called my local auto parts and they can't find either part. Any ideas on where to find them? Any tips on making it easier? Thanks again very much for the help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors