Truck temp hot when pulling???? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-22-2013, 05:30 PM
Member
 

Join Date: Apr 2012
Posts: 88
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck temp hot when pulling????

Hey guys,

I have a friend with a 95 f350 and his truck runs hot when he pulls his camper... Well we thought it might be his fan clutch so we replaced it and nada... So we asked a shop about radiator and he said they rarely fail or need replacing... Do the oil coolers on these truck ever fail or need cleaning? I have a 6.0 so I not familiar with the older 7.3..He don't have any gauges he is just going off the factory temp gauge.. Without pulling it shows below N and when pulling it gets past the AL.. Any advise ???

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-22-2013, 05:53 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Northern Arizona
Posts: 1,843
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 4 reviews
Try swapping in a 6.0 fan. I would also check what the engine temp actually is, the dash gauges aren't all that accurate.
Reply With Quote Quick reply to this message
  #3  
Old 03-22-2013, 06:23 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,036
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
May have a bad temp sender, dirty radiator, bad water pump, dirty cooling system, worn out coolant.
Reply With Quote Quick reply to this message
  #4  
Old 03-23-2013, 02:34 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Gilbert PA
Posts: 1,901
Thanks: 2
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Full of coolant?
Reply With Quote Quick reply to this message
  #5  
Old 03-23-2013, 04:34 PM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: jamestown, nd
Posts: 447
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Truck temp hot when pulling????

Also would maybe try replacing the belt if its slipping it won't drive water pump or fan fast enough. Had that same issue once turned out to be belt


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 03-23-2013, 04:52 PM
Member
 

Join Date: Apr 2012
Posts: 88
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys.. This site is awesome like always.. When we find the culprit ill post it up.. Thanks again
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:28 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors