Possible CPS Problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-24-2013, 10:19 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Exclamation Possible CPS Problems

Today, my 94 PSD has been having intermittent stalling issues. It stalled once turning into a parking lot, but it caught and idled backup before stalling completely. When this happened, the truck was running normally, but the wait to start light was on. A few hours later, I was driving about 30 mph when it stalled, in gear. The tach was still showing RPMs. After stopping on the side, the motor very reluctantly restarted, after a longer than normal cranking time. When it was running, the CEL remained on. About a half mile later, the CEL was still on, and as I shifted to 4th and began to accelerate at around 1000 RPMS, it stalled again. I stopped, and rolled it backward into a parking lot. I turned off the ignition, and restarted it. The wait to start light would flicker off, and the CEL would come off, then the WTS light came back on. This repeated about 3 times, but the engine started readily when I cranked it with a big puff of white smoke. I drove an additional mile or so with no problems. Does this indicate a CPS failure? I never noted an issue with the tach.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-24-2013, 11:33 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Nunn, Colorado
Posts: 839
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i think almost anything on these trucks can be a CPS failure, i was always under the impression that if the thing acts up in any way, change it out with one you know is good and see if that fixes the problem. so if you have a spare, throw it on
Reply With Quote Quick reply to this message
  #3  
Old 02-24-2013, 11:48 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I have one, might as well swap it.
Reply With Quote Quick reply to this message
  #4  
Old 02-24-2013, 11:53 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Nunn, Colorado
Posts: 839
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah throw that on and see what happens, itll take ya 10 minutes
Reply With Quote Quick reply to this message
  #5  
Old 02-24-2013, 03:51 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Got it swapped. It fired right up, and died after it had run about 30 seconds.I checked the fuel bowl and the HPOP reservoir, both were full. I pulled the ICP sensor plug. Started up just fine, and ran about 3 minutes before it stalled. I was still noting the flickering WTS and CEL, so I picked up relays to replace the PCM and IDM relays. It started up normally, and has been running about ten minutes so far.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:54 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors