94 7.3 IDI injector pump trouble - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-30-2013, 10:43 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
94 7.3 IDI injector pump trouble

Hey guys, I got a 1994 f-250 7.3 idi non-turbo and I have to hunt down an injector pump for it. Can you guys point me in the right direction to find an injector pump for it?
Jesse302boss is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-30-2013, 11:06 AM
Compression Ignition Addict
 
2000-7.3L's Avatar
 
Join Date: Aug 2012
Posts: 4,167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Auto or manual
2000-7.3L is offline  
post #3 of 5 Old 01-30-2013, 11:36 AM
Compression Ignition Addict
 
Join Date: Dec 2011
Location: Northern Arizona
Posts: 2,164
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 4 reviews
If possible you will be much better off to send yours to a injection shop for repair or rebuild

Jack
97 F250 Xlt, built E4od, D60 swap, Baby swamps, tunes by Dp
1.0 turbo housing, 203* t-stat, diy 6637, 4" exhaust
Diy intercooled, 6.0 fan, Diy 140v Idm, Isspro Ev gauges
On board air,E-fuel, 5" lift on 35's
320000 miles
1Dieselman is offline  
post #4 of 5 Old 01-30-2013, 04:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok. Ill just tell you guys whats the deal with this thing and maybe I'm barking up the wrong tree all together. Little back story... We did an engine swap. Its a 7.3 IDI non-turbo that came out of a school bus. I heard it run, and it sounded and ran great. Bought the motor, did the swap, leaving its injector pump on. The engine has a little trouble starting, but it fires up and idles fine. When your going down the road its fine, but lets say your coming up to a stop. You let your foot off the petal the truck stalls out. If you let your foot off the pedal slowly it wont stall, kind of keeping the rpms at 2,000. The mechanic I'm using right now is pointing to the injector pump.

My question now is: Is it the injector pump? Or could it be something else?
Jesse302boss is offline  
post #5 of 5 Old 01-30-2013, 05:52 PM
Compression Ignition Addict
 
Join Date: Dec 2011
Location: Northern Arizona
Posts: 2,164
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 4 reviews
That is the injection pump. It has something to do with a scored piston inside the pump.

Jack
97 F250 Xlt, built E4od, D60 swap, Baby swamps, tunes by Dp
1.0 turbo housing, 203* t-stat, diy 6637, 4" exhaust
Diy intercooled, 6.0 fan, Diy 140v Idm, Isspro Ev gauges
On board air,E-fuel, 5" lift on 35's
320000 miles
1Dieselman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome