97 "farm truck" - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-13-2013, 10:35 AM Thread Starter
Powerstroke.org Rookie
Join Date: Dec 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 7.3 stalling issue

Ok ,so I have reviewed lots of the topics here without resolution. This is a 7.3 w/about 195k miles. we use it as a "farm truck" in part due to this issue, it sits a lot. It has occured 3-4 times out on the road. a bit hard starting all the time, but will run fine and suddenly lose power and stall like a fuel loss. Will not restart period. after a recent failure that left us at a friends house I Installed an OEM CPS with the blue Oring. The #5 fuse was blown also. The same stall occured at the typical 10-12 mile distance on the way home. added fresh fuel to address that issue, air and fuel filters look fine. All fuses are good. new batteries allow it to crank easier but it idles very rough and has a skipping sensation with increased RPMs.


Last edited by silverbackP; 01-13-2013 at 11:28 AM.
silverbackP is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome