HELP! WITH TURBO SPUTTER - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-22-2012, 06:28 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Brfootball45
HELP! WITH TURBO SPUTTER

i have a 95 powerstroke , edge chip with intake and exhaust ... tonight i disconnected the EBPV plug to stop it from killing my mpg. but now after starting it and go to take off the turbo makes a sputter noise, but goes away after driving a min or two after starting up. could this be the valve fluttering in the turbo? it never did this before unplugging
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-22-2012, 06:32 PM
Premium Member
 

Join Date: Apr 2011
Location: rhode island
Posts: 1,000
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to baderic03
Well first mpg shouldn't change w it unplugged or not and flutter check turbo play
Reply With Quote Quick reply to this message
  #3  
Old 03-22-2012, 06:41 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Brfootball45
but it never did it before though? it did it after unplugging the ebpv
Reply With Quote Quick reply to this message
  #4  
Old 03-22-2012, 07:14 PM
Premium Member
 

Join Date: Apr 2011
Location: rhode island
Posts: 1,000
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to baderic03
Well reach under and see if u can move the blade with it still attached. The valve is spring loaded open so it shouldn't matter unplugged or not. If you live where it's cold don't hammer on the truck till it warms up
Reply With Quote Quick reply to this message
  #5  
Old 03-22-2012, 07:23 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,043
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by baderic03 View Post
Well first mpg shouldn't change w it unplugged or not and flutter check turbo play
If it's closing when it shouldn't, it'll matter.
Reply With Quote Quick reply to this message
  #6  
Old 03-23-2012, 09:20 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: brighton,MI
Posts: 756
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
did you disconnect the sensor or the rod?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors