Issue with engine hesitating, looking for help.. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2011, 06:17 PM
Member
 

Join Date: Feb 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Issue with engine hesitating, looking for help..

I have a 97' and started it the other day. Started fine as usual, drove it about 1/4 mile and seemed like truck lost power. I turned into a neighbors driveway and engine was barely running. Was almost like only a couple cylinders were working. Shut off engine and checked under hood. Fuel filter looked really dirty and I thought maybe it was the CPS, but I was seeing RPM's on tach when cranking engine. It started back up and I revved the engine a bit. Sounded like it was idling normally. Took it home and changed the CPS and the fuel filter. Ran normally but when I shut if off and start it back it back up, engine "lopes" until I give it some gas and then it idles normally again. Any ideas on what this could be?

Mac
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-24-2011, 06:29 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel pressure. Frp screen clogged? I just woke up....I apologize if i am far off!
Reply With Quote Quick reply to this message
  #3  
Old 10-24-2011, 08:10 AM
Member
 

Join Date: Feb 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where is the FRP screen located? Have not checked the fuel pressure yet.
Reply With Quote Quick reply to this message
  #4  
Old 10-25-2011, 09:58 AM
Member
 

Join Date: Feb 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone?? Looking to try to resolve this issue..
Reply With Quote Quick reply to this message
  #5  
Old 10-25-2011, 10:18 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,380
Thanks: 0
Thanked 7 Times in 3 Posts
Feedback Score: 2 reviews
Have you checked uvch?
Reply With Quote Quick reply to this message
  #6  
Old 10-25-2011, 07:36 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 488
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Lope idle generally indicates bad ICP sensor. IT's on the front of the driver head, right behind the HPOP. Pull the plug off with it running and see if it idles better.
Reply With Quote Quick reply to this message
  #7  
Old 10-26-2011, 04:38 AM
Member
 

Join Date: Feb 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll check the ICP sensor and FRP screen tonight. (Searched and found where to locate both. Still relatively new to diesels.) Not sure what the UVCH is but I'll search on that as well and figure it out.

It's not fun having this happen while you are on the boat ramp and you have 10,000 lbs you need to pull up the ramp like happened last night!

Thanks
Reply With Quote Quick reply to this message
  #8  
Old 10-26-2011, 04:50 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Glen Allen Va
Posts: 514
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Under Valve Cover Harness, this powers your glowplugs and injectors and they have been know to short and burn.Check for bad and burnt connectors outside of valve covers and some do a smell test thru oil cap,electrical burn smell.The harness can fry inside cover.Check the IDM for water saturation,the little brain box located down on the left fender near cowl,they have been prone to collect moisture and give an intermittent running issue such as not running on cylinders.
Reply With Quote Quick reply to this message
  #9  
Old 10-26-2011, 05:20 PM
Member
 

Join Date: Feb 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the info Chop. I'll take a look at it tonight.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors