New Injectors...No start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 10-23-2011, 05:50 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2010
Posts: 537
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
New Injectors...No start

So I sent my injectors off to Rosewood, and got everything buttoned back up except the valve covers. Now I've got a no start. My batteries are from last year (675CCA Interstates), but I'm suspecting I have a tired starter. It cranked well to purge the cylinders, but when I got the injectors and glow plugs in it, there wasn't enough cranking RPM to register on the tach. Also, I filled the HPOP reservoir up, but I'm not getting any oil from the spouts on the injectors (and the truck has a known weak LPOP), so should I go ahead and swap starters, charge the batteries up, refill the reservoir, and try it again? Or are there any other suggestions? The truck has probably been cranked at less than 100 RPM for about a minute since the injectors were installed.
sgg93 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 10-23-2011, 06:06 PM
Compression Ignition Addict
 
clatterindiesel's Avatar
 
Join Date: Dec 2010
Location: Inglis, Florida
Posts: 716
Thanks: 7
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i know thus may sound dumb....but are the harness plugged in. All of them.
clatterindiesel is offline  
post #3 of 10 Old 10-23-2011, 06:08 PM
Compression Ignition Addict
 
clatterindiesel's Avatar
 
Join Date: Dec 2010
Location: Inglis, Florida
Posts: 716
Thanks: 7
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Perhaps use another truck to jump yours while cranking. That's what I had to do. And it worked. Also, u will have to crank for a while to get everything primed and purged again.
clatterindiesel is offline  
post #4 of 10 Old 10-23-2011, 06:21 PM
Compression Ignition Addict
 
kkbodyshop's Avatar
 
Join Date: Sep 2008
Location: anderson
Posts: 221
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i jus replaced my injectros and i had to crank on mine to get it started untill all the air got out. once i got mine to start i drove it around


94.5 f350 dually
216k miles
straight piped
intake
fuel shim
ts chip
kkbodyshop is offline  
post #5 of 10 Old 10-23-2011, 07:28 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2010
Posts: 537
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
I did get all the harnesses plugged in. I'll try the jump start trick if I can't get hold of a charger. I guess I need to keep the HPOP reservoir full. Thanks guys
sgg93 is offline  
post #6 of 10 Old 10-24-2011, 05:56 AM
Compression Ignition Addict
 
clatterindiesel's Avatar
 
Join Date: Dec 2010
Location: Inglis, Florida
Posts: 716
Thanks: 7
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Good luck. Where are u located, I could possibly lend a hand.
clatterindiesel is offline  
post #7 of 10 Old 10-24-2011, 07:26 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2010
Posts: 537
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Asheville, NC.
sgg93 is offline  
post #8 of 10 Old 10-24-2011, 07:37 AM
Compression Ignition Addict
 
clatterindiesel's Avatar
 
Join Date: Dec 2010
Location: Inglis, Florida
Posts: 716
Thanks: 7
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
O. I'm in Florida, sorry. But perhaps one of the fellas on here local to u could lend a hand.
clatterindiesel is offline  
post #9 of 10 Old 10-24-2011, 10:54 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2010
Posts: 537
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Never mind. Got it running.
sgg93 is offline  
post #10 of 10 Old 10-24-2011, 08:12 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2010
Posts: 537
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Well I was driving it around today and finally got the smoke cleared up after 25 or so miles. Pulled it into the driveway and popped a power steering line Can't win 'em all.
sgg93 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome