New Injectors...No start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2011, 04:50 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 485
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
New Injectors...No start

So I sent my injectors off to Rosewood, and got everything buttoned back up except the valve covers. Now I've got a no start. My batteries are from last year (675CCA Interstates), but I'm suspecting I have a tired starter. It cranked well to purge the cylinders, but when I got the injectors and glow plugs in it, there wasn't enough cranking RPM to register on the tach. Also, I filled the HPOP reservoir up, but I'm not getting any oil from the spouts on the injectors (and the truck has a known weak LPOP), so should I go ahead and swap starters, charge the batteries up, refill the reservoir, and try it again? Or are there any other suggestions? The truck has probably been cranked at less than 100 RPM for about a minute since the injectors were installed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-23-2011, 05:06 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i know thus may sound dumb....but are the harness plugged in. All of them.
Reply With Quote Quick reply to this message
  #3  
Old 10-23-2011, 05:08 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Perhaps use another truck to jump yours while cranking. That's what I had to do. And it worked. Also, u will have to crank for a while to get everything primed and purged again.
Reply With Quote Quick reply to this message
  #4  
Old 10-23-2011, 05:21 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: anderson
Posts: 221
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i jus replaced my injectros and i had to crank on mine to get it started untill all the air got out. once i got mine to start i drove it around
Reply With Quote Quick reply to this message
  #5  
Old 10-23-2011, 06:28 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 485
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
I did get all the harnesses plugged in. I'll try the jump start trick if I can't get hold of a charger. I guess I need to keep the HPOP reservoir full. Thanks guys
Reply With Quote Quick reply to this message
  #6  
Old 10-24-2011, 04:56 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good luck. Where are u located, I could possibly lend a hand.
Reply With Quote Quick reply to this message
  #7  
Old 10-24-2011, 06:26 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 485
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Asheville, NC.
Reply With Quote Quick reply to this message
  #8  
Old 10-24-2011, 06:37 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
O. I'm in Florida, sorry. But perhaps one of the fellas on here local to u could lend a hand.
Reply With Quote Quick reply to this message
  #9  
Old 10-24-2011, 09:54 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 485
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Never mind. Got it running.
Reply With Quote Quick reply to this message
  #10  
Old 10-24-2011, 07:12 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 485
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Well I was driving it around today and finally got the smoke cleared up after 25 or so miles. Pulled it into the driveway and popped a power steering line Can't win 'em all.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors