Oil pressure and a few other questions - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-11-2010, 12:34 PM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2010
Location: Houghton, MI
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oil pressure and a few other questions

I bought a 95 F250 with 284k miles on it a month ago. The previous owner had passed away and no one knew anything about the truck or what had been replaced on it. My main concern is the oil pressure gauge jumps right to max a few seconds after start up and stays there. The truck runs fine other than taking about 5 seconds to start and then it runs a bit rough for a bit and pours out white smoke. Also, the turbo has "Garrett" stamped on it, is that stock?
Any advice or pointers would be great. This is my first diesel so i have a lot to learn yet. Thanks
rrkaunis is offline  
Sponsored Links
post #2 of 3 Old 09-11-2010, 12:43 PM
Compression Ignition Addict
powerhoghp's Avatar
Join Date: Sep 2009
Location: Hedgesville, WV
Posts: 1,256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would say the sensor is shorted out or bad if the needle is pinned like that. The white smoke is most likely unburnt fuel untill the engine warms up a bit. And these trucks were factory turbocharged by garrett.
powerhoghp is offline  
post #3 of 3 Old 09-13-2010, 11:23 AM
Compression Ignition Addict
ridiculously_necessary's Avatar
Join Date: May 2008
Location: Blue Springs, MO
Posts: 4,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

your in the right place! x2 on powerhog's post. you could have a bad oil pressure sensor, i would check there first. white smoke on a cold startup is normal to a degree, if its does it for more than 10 seconds or so then id check into some things. ive never had white smoke above 40* F. and i have 4 bad glows. a rough idle is normal for a few seconds. can you post a startup vid? did you get a good deal?

be sure your starting and charging system is to spec, i see you live in MI. batteries, alternator, glows, glow relay, starter. if you need to replace glows or glow relay before the cold, us onyl the motorcraft ZD11's (not autolite) and a stancor 586-902 relay. (aftermarket)


Late 99 (2/99) Black F250, CC LB 4x4 Lariat 214k. All Stock for the moment...

1995 PSD, ext cab, one wheel wonder , 297k miles, 30k on wvo. totaled 5/8/11 RIP This truck is for sale as a parts truck (Jason is about to receive forged rods, and drop kick his PMR's)
DB high torque starter
DIY 6637
Marinco Mod
DIY Electric fuel w/ wvo conversion

"A clean house is a sign of a mis-lead life."
ridiculously_necessary is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome