FUEL PUMP - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 09-11-2010, 10:51 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2010
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FUEL PUMP

ok so my truck stalled 4 times in the last 3 days, and when i went to start my truck this mornin it took like 10 seconds for it to start, is my fuel pump goin out? oh and the fuel filter is brand new. thanks

96 f-250 psd
afe cold air
mbrp 4inch
305/70/16 cooper discovers on micky tompson classic II wheels
Powerstrokesmoke99 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 09-11-2010, 11:55 AM
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would check your camshaft position sensor. My truck kept stalling and than wouldnt start. The 7.3 are famous for the Camshaft Position Sensor going bad. You can get them at most auto parts store for around $25-$30.
jpdaniels1 is offline  
post #3 of 12 Old 09-11-2010, 02:40 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2010
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well it starts but it just takes awhile in the mornin then its fine the rest of the day.

96 f-250 psd
afe cold air
mbrp 4inch
305/70/16 cooper discovers on micky tompson classic II wheels
Powerstrokesmoke99 is offline  
post #4 of 12 Old 09-11-2010, 04:35 PM
Compression Ignition Addict
 
miked.'s Avatar
 
Join Date: Oct 2008
Location: killen, alabama
Posts: 387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine was doing that also. it would all most cut off then take off again.i think it was water in the fuel. changed filter and added ceafaom straight to the fuel filter canister and to the tank. been good to go so far.
miked. is offline  
post #5 of 12 Old 09-11-2010, 04:43 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2010
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yea but wouldnt the water in fuel light come on the dash?

96 f-250 psd
afe cold air
mbrp 4inch
305/70/16 cooper discovers on micky tompson classic II wheels
Powerstrokesmoke99 is offline  
post #6 of 12 Old 09-11-2010, 05:06 PM
Compression Ignition Addict
 
UNDERCOVER_73's Avatar
 
Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,393
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 11 Times in 3 Posts
Feedback Score: 2 reviews
those are symptoms of the CPS tottaly.. same prob with mine... it would stall randomly on the freeway going 80. and wouldnt start sometimes. finnaly got it fixed after 1000 buks..
just replace it for liek 20-30 and your good to goo

-06 F250 SCSB 6.0 191k
TSD Super Panty Dropper
190/100s
Gt4294 Turbo
5" Exhaust
Airaid intake
Studded and Deleted.
50" Led Light Bar
4" lift 37x14s

-04 Crown Vic P71 interceptor 160k


UNDERCOVER_73 is offline  
post #7 of 12 Old 09-11-2010, 07:21 PM
Member
 
Join Date: Jan 2010
Location: Clintonville, WI
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Powerstrokesmoke99 View Post
well it starts but it just takes awhile in the mornin then its fine the rest of the day.
Sounds like the glowplug relay crapped out. I would check that. Mine started hard in the morning, but fine the rest of the day when my gp relay died.

1996 F350 Crew Cab Long Box
7.3L Powerstroke, E4OD Auto
Banks Intercooler, Banks Quick-Spool Turbo, NAPA 6637 Air Filter, 4" Diamond Eye SS Turbo back exhaust
Bumper Dude Front and Rear replacement Bumpers

Future Mods: PHP FU chip, Gauges
Mezz2006 is offline  
post #8 of 12 Old 09-11-2010, 09:48 PM
Compression Ignition Addict
 
350ninty7's Avatar
 
Join Date: Mar 2010
Location: Washington State
Posts: 272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 11
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Ford replaced my CPS for my 97 in April. I received a couple of recall notices last year and finally took it in. I don't know if they have upgraded the sensor?This is the 3rd CPS I have replaced. Both cases were classic, engine would just shut down for a few seconds then start running. For me it was always crusing down the Freeway at 65 - 70 and it was like I turned off the ingnition.



2012 F350 XLT 6.7 CC LWB SRW
11,500 GVW FX4 Off Road, Camper, & Prem XLT Options
2012 Montana Mountaineer 326 5th Wheel

SOLD and Missed
1997 F350 XLT 7.3 Liter Power Stroke
Reg Cab 4X4 Off Road Pkge
5 spd Manual with South Bend Clutch Upgrade
AFE Stage 2
Diamond Eye 3" Down Pipe 4" Exhaust Cat Delete
TW Tunes
WARN Winch
Original Owner 179,000 Miles
350ninty7 is offline  
post #9 of 12 Old 09-12-2010, 07:30 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2010
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mezz2006 View Post
Sounds like the glowplug relay crapped out. I would check that. Mine started hard in the morning, but fine the rest of the day when my gp relay died.
thats what i thought too but it only gets down to 50 degrees here and it cranks over just fine it just doesnt want to go.

96 f-250 psd
afe cold air
mbrp 4inch
305/70/16 cooper discovers on micky tompson classic II wheels
Powerstrokesmoke99 is offline  
post #10 of 12 Old 09-13-2010, 11:28 AM
Compression Ignition Addict
 
ridiculously_necessary's Avatar
 
Join Date: May 2008
Location: Blue Springs, MO
Posts: 4,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could be a weak fuel pump, bad icp sensor, tired hpop. unplung the icp sensor then try to start it. it should default values. if it works better its your icp, if not then back to the drawing board. are you leakign any fuel in the valley or on the ground? can you get access to a liquid filled gauge to check the fuel pressure? a cps is a cheap trial, good to ahve a spare anyway.

-Matt

Late 99 (2/99) Black F250, CC LB 4x4 Lariat 214k. All Stock for the moment...

1995 PSD, ext cab, one wheel wonder , 297k miles, 30k on wvo. totaled 5/8/11 RIP This truck is for sale as a parts truck (Jason is about to receive forged rods, and drop kick his PMR's)
DB high torque starter
DIY 6637
Marinco Mod
DIY Electric fuel w/ wvo conversion

"A clean house is a sign of a mis-lead life."

Last edited by ridiculously_necessary; 09-13-2010 at 11:41 AM.
ridiculously_necessary is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome