Im a new STROKER addict, and got some Q's - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-19-2007, 03:18 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Stayton, Oregon
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Im a new STROKER addict, and got some Q's

i just got my first stroker (95 F250 PSD 5 speed 4x4) and im exstaic. But after2 days owining it, driving down the she started chuging, coughing and sputering then died.about 15 min latter she fired up and made it back home. now she idles rough, has a miss, and puffs blue smoke. along with that ive got a fair amount of blow by comeing out of the oil filler cap, and dipstick tube. Any thoughts?
sorry its so long, im new to the site.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-19-2007, 05:06 PM
Is it even worth it???



 
Join Date: Aug 2006
Location: Lex KY
Posts: 9,093
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to ABOBB Send a message via Yahoo to ABOBB
Welcome to Powerstroke.org

I'll let the experts answer your questions.. someone should see it and help you soon.
Reply With Quote Quick reply to this message
  #3  
Old 04-19-2007, 10:51 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Stayton, Oregon
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Aaron
Reply With Quote Quick reply to this message
  #4  
Old 04-20-2007, 02:41 AM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
At first it sounds like a CPS issue, but the other stuff I am not sure about
Reply With Quote Quick reply to this message
  #5  
Old 04-20-2007, 04:49 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Welcome! Let me bump this up to see if some of the smart guys can help ya.
Reply With Quote Quick reply to this message
  #6  
Old 04-20-2007, 10:48 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Stayton, Oregon
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for all the help, a friend mentioned some thing about injector O rings? anybody know anything about this?
Reply With Quote Quick reply to this message
  #7  
Old 04-20-2007, 11:35 AM
Member
 

Join Date: Apr 2007
Location: Caseville Michigan
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to 7.3pw뮧rk rt10r
It may be injectors, or bad compression in one of the cylinders. Im not really sure, but im just gonna wait until one of the mechanics say something. I may have another awnser. When I get back from working (Im a Mechanic in progress) Ill ask a few people, could be a few different things CPS, Injector, Compression are some of the most recent that I have seen come in to our shop. Well Ill be back to awnser if no one else does.
Hope to see you get her fixed, Sorry about the innconvinence of the new truck BUMMER!
Reply With Quote Quick reply to this message
  #8  
Old 04-20-2007, 02:11 PM
BIG TRUCK, SMALL DRIVER
 

Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to the Forum!

How many miles are on it?
Reply With Quote Quick reply to this message
  #9  
Old 04-21-2007, 12:56 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Stayton, Oregon
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, im workin on checkin the compression in the next couple days. Derrick the truck has 147k on it
Reply With Quote Quick reply to this message
  #10  
Old 04-21-2007, 03:13 PM
7.3 tech, supporter

 

Join Date: Jul 2006
Location: Wichita KS
Posts: 1,224
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Go ahead and check the compresion and we can talk about the blowby after you get that done. Sure sounds like the missing and dieing are a CPS (cam position sensor) issue, it is a comon problem and an easy fix. Did the tach do anything wierd when it died??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors