Ive got 2 issues need some help. Injectors and Starting - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-27-2010, 11:21 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ive got 2 issues need some help. Injectors and Starting

Ive changed the injector oring and still has blue smoke and studder around 2300 rpms before it revs all the way up. What is the problem?

When I try to start it up I has to crank for a while before starts up. The fuel pressure gauge shows that doesnt have any and when it builds up as you crank it and then I will start. What do I need to fix?

The fuel filter light comes on after driving for a while. But goes out when I let off and comes on when I get on it. Could it be the fuel pump cant keep up? The entire fuel system is clean

Last edited by Chadahootchie; 01-27-2010 at 06:41 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-27-2010, 06:42 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I havent been able to drive this truck in 2 weeks because its too risky
Reply With Quote Quick reply to this message
  #3  
Old 01-27-2010, 06:52 PM
Shade tree mechanic


 

Join Date: Mar 2008
Location: Lake Tapps, Wa.
Posts: 8,284
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I would have the injectors buzz tested. Is the smoke blue all the time, or just on cold start up?
Reply With Quote Quick reply to this message
  #4  
Old 01-27-2010, 06:54 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 95dieselsmoke View Post
I would have the injectors buzz tested. Is the smoke blue all the time, or just on cold start up?
The motor idle really good and its acually real quite you can the injector over the motor. The blue smoke is at start up alittle but goes away it smoke at around 2300 when is spudder a little and clears up when it get s past it. Its only at that rpm. The truck has no blow by at all not even a little out of the oil cap like most truck do
Reply With Quote Quick reply to this message
  #5  
Old 01-27-2010, 07:40 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: killen, alabama
Posts: 387
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
guessing, the fuel pump can't keep up. that or regulater
Reply With Quote Quick reply to this message
  #6  
Old 01-28-2010, 04:24 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just put a used regulator for a member on it because the old on was bad
Reply With Quote Quick reply to this message
  #7  
Old 01-28-2010, 04:31 AM
OBS Forever!!!!!!

 

Join Date: Feb 2009
Location: China Grove, NC
Posts: 5,557
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Take a look at the fpr screen too.
I cracked my fpr(long story) and had to replace it and the joint between the fpr assembly and bowl was gunked up so bad I was surprised it could run at all.
Reply With Quote Quick reply to this message
  #8  
Old 01-28-2010, 08:33 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by oasis04 View Post
Take a look at the fpr screen too.
I cracked my fpr(long story) and had to replace it and the joint between the fpr assembly and bowl was gunked up so bad I was surprised it could run at all.
Thanks for the idea it clean also.

Does anybody know if the check ball in the regular could be an issue at all?
Reply With Quote Quick reply to this message
  #9  
Old 01-29-2010, 01:41 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
starting problem fixed itself guess it was because I just did the orings on the injectors but the fuel filter still comes one
Reply With Quote Quick reply to this message
  #10  
Old 01-29-2010, 05:46 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update fuel bowl does not stay full its about half full right now and the fuel filter light comes on when I rev it up to 2000 rpms
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors