no heat - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-26-2010, 04:13 PM Thread Starter
Compression Ignition Addict
 
miked.'s Avatar
 
Join Date: Oct 2008
Location: killen, alabama
Posts: 387
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no heat

before i tear into this truck, does anyone know why a heater will not get hot. just changed the t=stat and replaced antifreeze. it gets warm, but when its mid 20's warm is not good enough for the wife.
miked. is offline  
post #2 of 2 Old 01-26-2010, 08:39 PM
Premium Member
 
ryandamo's Avatar
 
Join Date: Jun 2009
Location: Connecticut
Posts: 1,205
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
might be clogged try taking the heater hoses off and flushing it out, some times stuff builds up.


2016 F450 6.7L XLT 4x4Dump, bone stock
1994 F250 7.3L XLT 4x4 ZF5 , Centurion, 4" Lift, 6637, Gulf Coast Bypass Filter, Big fuel tanks, dana 60 swap, No longer dually
1997 F350 7.3L XLT 4x4Dump, E4OD, 4 in exhaust, TS 6 position, 3/8 Trans line+external filter
2013 Scag Turf Tiger 61" 1.1L Caterpillar Diesel
1960 John Deere 440 Backhoe 2-53 detroit
ryandamo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome