Electrical Problem! Help! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2010, 11:43 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical Problem! Help!

I started my truck up to come home form work, let it warm up for 5min, came back, and the shifter was stuck in park(automatic) and the abs light was flashing. Since I have had this happen once before quite some time ago I knew to change the # 13 15amp fuse. I did so and drove out. After I stopped to close the gate, it had blown again. Now I was mad. I found another fuse, jammed it in and pulled it in gear right before it blew again. Then i got a few blocks away and I went to signal and saw the flash of a fuse and lost my signal. My brake lights as well. I was too scared to flick from low to high beams from fear of losing all my lights. Would be great in a snow storm. All my other lights and accessories work.

Do I have a short somewhere in my fuse box? Heard of this before? I have to get to work tomorrow. Any ideas where to start. I am going to look for a short around the box but after that I am lost on where to look.

Any ideas would be great, thanks.

Ian
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-05-2010, 12:59 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Followed the wires from my brake pedal sensor, and found that it had been cut and spiliced. Found both wires had some exosed wire. Hard as hell to get at so I just added some tape for now. Its too cold out to do more. Hope that is the problem. Put in a fuse and it did not blow yet so I will find out on the way to work.
Reply With Quote Quick reply to this message
  #3  
Old 01-05-2010, 11:44 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Didn't even make it out th driveway before the fuse blew. But I did find the poblem after work. An aftermarket taler wiring adapter that pluged in between a factory plug to add a 4 wire trailer plug. Unplugged it and drove home with no problems. Hope this is it this time.
Reply With Quote Quick reply to this message
  #4  
Old 01-06-2010, 12:40 AM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: Needham AL
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know what you're talking about PO's work has been most of my....reasons? to have to work on mine. Later Whit
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors