problem charging system - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-04-2010, 07:07 PM Thread Starter Rookie
catahoulasr1's Avatar
Join Date: Jan 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
problem charging system

i have a 96 powerstroke with two different batteries one from car quest one from auto zone. i've replaced the alternator 4 or 5 times now in the past year and a half three days ago the alternator went out again. both batteries test good both at about 12.2 volts put the new alternator in about three days ago. can charge the batteries and will start. coming out of the alternator it tests low showin 12.2 should be testin somewhere around 13.5 at idle right? you can get in the pickup and watch the voltage meter and it is constantly movin back an forth. which is definately not the norm. so batteries test ok new alternator already looks bad. cheap alternator? a ground somewhere? but something seems to be pullin from somewhere killin alternators.
catahoulasr1 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome