Alternator - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-03-2010, 05:04 PM Thread Starter
Join Date: Aug 2009
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

My battery light has been bouncing on and off. I thought I had it traced to the wires on top of the alternator being "loose". But now no matter what I do I can't get it to go off. I am pretty sure it's charging fine since it starts fine and the voltage seems good. Ranges between 14.2 to 14.7 while driving and drops to 13v with it turned off. Anyone got any more thoughts? Maybe I need to dig into those wires on the top of the alternator some more.

FYI the set up below was really effective for anyone else out there looking to diagnose such a problem. Do be careful not to buy an adapter that has any kind of regulator in it. I almost did and it would have ruined my test.


Link to Radioshack
Enercell™ Vehicle Adapter Plug w/ Banana Jacks -

Here it's connected to the leads on my multimeter


'97 F250 7.3l
SC LB 4x4
280,000 miles

Last edited by blindlightguy; 01-03-2010 at 05:10 PM.
blindlightguy is offline  
Sponsored Links
post #2 of 2 Old 01-03-2010, 05:22 PM
Compression Ignition Addict
kw900driver's Avatar
Join Date: Feb 2008
Location: Sarver, PA
Posts: 432
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kw900driver
Hmmm i dont know what to tell ya. How long ago were your batteries changed?


'09 F-250 Lariat Crewcab Longbed
6.4 PSD
Spartan tuned
DPF deleted
Industrial Injection twins

EGR to be deleted once I get the blowoff valve installed and lots of other upgrades to come.


97 Ford F250 HD Supercab XLT Longbed
AFE Stage 2 Intake
3" dp
Bully Dog exhaust
Hypertech programmer-getting 6 pos chip soon
Hankook all-terrains on Mickey Thompson classic II
Autometer: Pyro, Trans, Boost guages in A-pillar
Beans IDM Mod
Dana 60 swap
kw900driver is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome