EBPV Qwerk - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-03-2010, 01:04 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Youngstown OH
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EBPV Qwerk

EBPV will work if I manually turn it on but it dosent do anything on its own. It usually works like a charm until the truck is completely warm. This started last week.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-03-2010, 02:15 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Sarver, PA
Posts: 428
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kw900driver
The valve is supposed to stay closed until you accelerate, then close again. It may be the valve is sticking slightly, and the actuator rod needs to be adjusted. But you should have someone monitor the exhaust pressure regulator to see the valve is acting as commanded or not (staying closed when commanded open).
Reply With Quote Quick reply to this message
  #3  
Old 01-03-2010, 02:25 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Sarver, PA
Posts: 428
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kw900driver
And I was told by the idle pully in the front of the motor there is a sensor, it is the exhaust back pressure sensor, the tube that it is mounted on is plugged with soot, clean it out and your back pressure valve will work as it is intended to. Its what I am goin to do to mine tomorrow.
Reply With Quote Quick reply to this message
  #4  
Old 01-04-2010, 03:42 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Youngstown OH
Posts: 713
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oh that was the first thing that I would do but that is not the issue. If it was staying closed then it would be. My issue is that it is not closing at all. The PCM is not telling it to. Because if I put it on high idle w/ebpv on my DP tuner it will work.
Reply With Quote Quick reply to this message
  #5  
Old 01-04-2010, 01:16 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Sarver, PA
Posts: 428
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kw900driver
Oh okay got ya know, i just fixed mine, replaced the sensor and cleaned everything up and it works great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors