Transmission Trouble - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-17-2007, 05:56 PM Thread Starter
Powerstroke.org Fanatic
 
circle5's Avatar
 
Join Date: Feb 2007
Location: Dakota Territory
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Transmission Trouble

I was driving about 65 in OD and it popped into Drive and the OD light started flashing. It shifts hard from 1-2 but is fine from 2-3? New Transmission or maybe a sensor or solenoid??

Sorry wrong forum. This can be moved to the trannie problem forum

1997 Ford F350 Crew Cab, Long Box, 7.3L Powerstroke, E40D Automatic, ATS 5 Star Converter, ATS Deep Trans Pan, DIY Intake, Straight Exhaust, 4x4, SRW, 3:55 Rear End, Cab Lights, Lighted Grab Handles, Delta Champion Low Profile Tool Box, Dee Zee Box Caps, Homemade Drill Stem Rear Bumper.
Isspro Pyro and Boost, B&M Trans Temp Gauges.
DP Tuner F5 Stock,40,60 Tow settings
Alliant AC Code 160cc Injectors

Last edited by circle5; 03-17-2007 at 05:58 PM. Reason: Wrong Forum
circle5 is offline  
post #2 of 3 Old 03-17-2007, 06:11 PM
Powerstroke Techie

 
gbear's Avatar
 
Join Date: Feb 2006
Location: North Little Rock, Arkansas
Posts: 613
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to gbear
I'd say, #1 check the fluid level. Then get the codes read for the transmission. The flashing OD light means one should be set.

Jim

95 F-250 Extended Cab with 3 Gage Piller Pod and BTS Transmission Super Duty Transmission cooler
74 Jeep CJ-5 304 V8
67 Mustang Coupe 289 V8
2002 Explorer
54 F100 Project Truck
27 Model T Pick-up Project Truck
gbear is offline  
post #3 of 3 Old 03-17-2007, 07:37 PM
7.3 tech, supporter

 
fordnut85's Avatar
 
Join Date: Jul 2006
Location: Wichita KS
Posts: 1,224
Thanks: 0
Thanked 2 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by gbear View Post
I'd say, #1 check the fluid level. Then get the codes read for the transmission. The flashing OD light means one should be set.

Jim
Ditto, sounds like a pump failure

Duane

1994.5 F-350, PSD, 5spd, Crew cab, 2wd, DRW
10k mod
Idle control mod
homeade exhaust brake
Tymar intake

fordnut85 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome