Black Betty's hiccups - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2007, 07:40 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Black Betty's hiccups

Well a while back i put up a thread saying black betty had the hiccups. I had just replaced the ICP and about a month later from that. it started to act up, throwing codes for ICP sensor circuit low. I thought to myself why in blazes is it acting up now i just changed the thing. It stalled on me twice but always started up great. Started great everymorning, but always seemed like something wasn't right. So i put the old ICP back in, the only reason i changed it out was to attempt to fix a varrying idle situation. When i got the new one out i say that the plastic connector piece that connects to the connector was broke almost off...i don't know how that happened. I finaly concluded that it was missing...its hard to tell cause it still ran hard and strong it just didn't sound right. So i took it down to the local diesel shop...i don't have my scan tool yet to run a cylinder contribution or buzz test... Well they are thinking that i dropped an injector...i took it there on monday and haven't heard anything from them yet...i hope that means my extended warranty is going to cover the expense. Ill keep yall informed when i hear more (there was a couple of ya i was talking to about it).
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-14-2007, 09:19 PM
Compression Ignition Addict
 

Join Date: Jul 2006
Location: OREGON
Posts: 1,109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sucks man. I hate not having my truck, hopefully they let you know whats going on soon, and they fix it under warranty. Looking forward to a good report.
Reply With Quote Quick reply to this message
  #3  
Old 03-18-2007, 07:19 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well they figured it out...It dropped number 6 injector and it is going to be back to me tomorrow afternoon...warranty covered it and i didn't even have to take off any power adders.
Reply With Quote Quick reply to this message
  #4  
Old 03-18-2007, 09:01 PM
7.3 tech, supporter

 

Join Date: Jul 2006
Location: Wichita KS
Posts: 1,224
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sweet man!!!
Reply With Quote Quick reply to this message
  #5  
Old 03-19-2007, 06:08 PM
Compression Ignition Addict
 

Join Date: Jul 2006
Location: OREGON
Posts: 1,109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good to hear, are they gonna replace all the o-rings on the rest of the injectors while they are in that far? Hopefully I'll be back in my truck by this weekend, still waiting on my part.
Reply With Quote Quick reply to this message
  #6  
Old 03-20-2007, 04:41 PM
7.3 tech, supporter

 

Join Date: Jul 2006
Location: Wichita KS
Posts: 1,224
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
All under warranty?? Dude, that's friggin awesome!!
Reply With Quote Quick reply to this message
  #7  
Old 03-20-2007, 07:05 PM
Compression Ignition Addict
 

Join Date: Aug 2005
Location: Carroll County, IN, USA
Posts: 1,014
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to purduefarmboy460
what kind of extended warranty did you have????
Reply With Quote Quick reply to this message
  #8  
Old 03-21-2007, 03:36 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
well i bought what the dealer offered me when i bought the truck...i was skeptical but thank god i bought it...when i first got it i went through 7 GALLONS of oil in the first month...turns out that two of the injectors were leaking internally and we letting oil get into the fuel and i was burning it...the dealership took care of it and i never saw a bill. Now this happened almost two years later and all i had to pay was 100 bucks as the deductable. I still think the map sensor is jacked but i have a deal going on with one of the guys on here to get one cheap...mabe im paranoid but it still doesn't sound like its running quite right. Im gonna get my scan tool at the beginning of april so ill better be able to see what its doing.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors