ts performance chip problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2009, 02:49 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ts performance chip problem

1997 stroker with ts chip and have a problem with it working on the highest power level i think it is 150 hp. Its bogging down like its de fueling and it will not get up and go. like it starving for fuel, all other levels work fine. suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2009, 04:32 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BUMP Anyone???
Reply With Quote Quick reply to this message
  #3  
Old 08-13-2009, 05:43 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: newark,ohio
Posts: 623
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
your hpop might not be able to keep up with it
Reply With Quote Quick reply to this message
  #4  
Old 08-13-2009, 09:16 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2008
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had a TS chip before I did my stage 1's and it did something similar to what you are describing and ran sluggishly. I honestly think the ts tunes just aren't that great on our trucks. They are an off-the-shelf product which seem to be tuned more for the newer 7.3's. My suggestion would be to send it in and get it reburned with tw tunes, you won't be disappointed. The throttle response and overall performance is awsome.
Reply With Quote Quick reply to this message
  #5  
Old 08-14-2009, 05:58 PM
Premium Member
 

Join Date: Jan 2008
Location: Farmersville, Ohio
Posts: 775
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ditch the TS tunes go with Tony Wildman. I had ts tunes and my HPOP and it didnt like each other. It ran dogish on the high levels. Low it was fine but still didnt shift well. Went with tony Wildman tunes and it was night and day difference. It runs great now even in level 6 which is 120ish/extreme, dont smoke like an edge evolution but itll get up and boggy for a 232k 7.3 with stock injectors and hpop. Good luck and Cheers with the OBS
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors