vacuum pump - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-23-2009, 07:04 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
vacuum pump

anybody know if there is a way to clean them up and make them work. mine is dieing on me all of sudden its not making vacuum very fast
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-23-2009, 07:25 PM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,529
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
I don't think they can be rebuilt. but not sure.
Reply With Quote Quick reply to this message
  #3  
Old 07-23-2009, 07:34 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Location: glassport, pa
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine breaks every year the bearings blow out of them buy a lifetime warranty one from napa. i have a spare so i can fix it wen it breaks on the road.
Reply With Quote Quick reply to this message
  #4  
Old 07-23-2009, 09:28 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Memphis, TX
Posts: 1,373
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via AIM to Maverick1701
I just had to replace mine too
Reply With Quote Quick reply to this message
  #5  
Old 07-24-2009, 08:38 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine comes on all the time and the truck wont start untill the pump kicks off. Also right before the pump kicks off there is usually a light clicking noise from the dash. Never have been able to pin point it. It only does this after sitting for a while like over night. I have been thinking there is a vacuum leak but not sure what else could be causing this.
Reply With Quote Quick reply to this message
  #6  
Old 07-24-2009, 09:18 AM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,529
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
Quote:
Originally Posted by srswain View Post
Mine comes on all the time and the truck wont start untill the pump kicks off. Also right before the pump kicks off there is usually a light clicking noise from the dash. Never have been able to pin point it. It only does this after sitting for a while like over night. I have been thinking there is a vacuum leak but not sure what else could be causing this.
you sound like you are talking about the electric pump on a superduty. OBS trucks still use a manual belt driven pump. If yours is not starting when the pump is running check your battery cables for good connections. Also if you were have a vacuum leak problem your ac vents should default to defrost and not blow out of the regular vents.
Reply With Quote Quick reply to this message
  #7  
Old 07-24-2009, 10:04 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Double post

Last edited by DisturbedS10; 07-24-2009 at 10:08 PM. Reason: dbl post
Reply With Quote Quick reply to this message
  #8  
Old 07-24-2009, 10:06 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just replaced mine this week. 190k on the truck. Bought a new one from Napa. Only a 1 year warranty they claimed they don't make a lifetime pump anymore?? Mine blew out the bearings and snapped the shaft.
Reply With Quote Quick reply to this message
  #9  
Old 07-25-2009, 08:01 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Boynton Beach
Posts: 356
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah when if u pump the brakes a couple times it the pedal gets really hard and the air blows threw the defost. Also when I start the truck it takes a little bit before the air blows threw the vents
Reply With Quote Quick reply to this message
  #10  
Old 07-25-2009, 11:07 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Location: glassport, pa
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i payed $155 for mine at napa, i bought them about 6 years ago. ive probably taken them back 7 times.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors