Stock trailer wiring problem - Ford Powerstroke Diesel Forum
94-98 7.3L Exterior Discussion Body and Accessories Talk

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2010, 12:19 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Location: West Oakland
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stock trailer wiring problem

So, I've had this truck for 8 years and the trailer package has always worked flawlessly. However, recently I towed a uhaul trailer to Port Townsend and halfway through Oregon the right side brake and blinker stopped working. I checked all the fuses and the light on the truck still works, so I assumed it was the trailer and forgot all about after I returned home. Until Sunday when I hooked up my boat to take my dad fishing and noticed it again. Has anyone seen this? Just wondering before I tear into the dash to try to find it. I had an alarm installed a few months back but all the lights worked after that. Thanks for the help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-22-2010, 01:10 PM
the baconator
 

Join Date: May 2009
Location: Easton MD 21601
Posts: 10,340
Thanks: 5
Thanked 23 Times in 23 Posts
Feedback Score: 1 reviews
There are fuses under the hood that are just for the trailer lights. Did you check those?
Reply With Quote Quick reply to this message
  #3  
Old 06-22-2010, 02:26 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Farmersville/Dayton, Ohio
Posts: 3,307
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Yeah, double check the trailer light fuses, and check all the wiring on both the truck and trailer. Coming home from Michigan a couple years ago, my brothers OBS kept blowing the fuse for the running lights, at night, on the highway, with a 26 ft long enclosed trailer. Turned out there was a wire shorting out somewhere on the truck or trailer, so he fixed it and it was fine after that. It took him a while to find it.
Reply With Quote Quick reply to this message
  #4  
Old 06-22-2010, 02:58 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Location: West Oakland
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I checked the underhood fuses when this first happened on the road, even replaced a questionable one. They were all good at the time, still no lights though. The funny thing is I just went out and checked them and found the fuse for that light burned out. Ah Ha, at least I found the problem but something told me to dig a little deeper... I also found a crappy wire tap that was shorting under the dash, but on a wire for the tailights which are working fine, go figure.
So, the lessons learned today:
1) Don't rent any more trailers from Uhaul and
2) Don't take your truck to Best Buy to have an alarm installed

If you want something done right you have to do it yourself! Thanks for the help, I'll report back when I hook up the trailer again in a few days.

Last edited by vegestar; 06-22-2010 at 03:46 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors