TRANS HELP! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2009, 06:10 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: ithaca
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
TRANS HELP!

I got a Ford F350 single rear wheel. with the ever soo sweet E40D in it. i had it hooked up to the computer and it reads PO603 Inter control moduel K.A.M error..wtf is that? how do i fix it. plus a PO470 Exhaust Pressure senor current fault came up with it..are they related? my check engine light isnt on just the overdrive flasher is going nuts. PLease help me get my RIg back to its normal self.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-20-2009, 06:13 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,243
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
kam is the keep alive memory. you must have a chip/tuner in it.
Reply With Quote Quick reply to this message
  #3  
Old 05-20-2009, 06:13 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,241
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
p0603 means nothing ,are you running a programmer at all, and the p0470 , means the ebp sensor is bad and the tube goin to it is probably clogged and needs to be cleaned or replaced
Reply With Quote Quick reply to this message
  #4  
Old 05-30-2009, 05:27 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: ithaca
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I dont have any programmer on it tho so its completely stock...The tube? where is that last sensor located?
Reply With Quote Quick reply to this message
  #5  
Old 05-30-2009, 05:30 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: ithaca
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if the KAM doesnt mean anything then why is it throwing my tranny into safe mode? i replaced the Shift Control Moudel the other day i reset the batt and they light hasnt came on when i had it running but im afriade of driving it and having it come back on i dont know what to do or where to go from this? could my PCM be bad? i was told there would be more than one thing wrong with my truck if that was the case. I WANT MY BABY BACK! im sick of drivin a GASS GMC!!!!
Reply With Quote Quick reply to this message
  #6  
Old 01-23-2010, 11:51 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: ithaca
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could someone tell me where the tube is that i need to clean then?.. IM stumped on this damn tranny i hate the e40d its started back up with the od light flashing outta the blue
Reply With Quote Quick reply to this message
  #7  
Old 01-29-2010, 02:12 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Posts: 1,166
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
On the front of the eng, about 3 inches from the thermostat houseing is the epb switch. Crawl under the vehicle and look at the front bottom of the passenger side exhaust manifold. That's where the exhaust pressure goes thur a pipe up to the ebp switch. Get a new pressure switch, remove the pipe and clean it. The switch is kinda hard to get off. There is a small bracket that the pipe goes thru. Makes it hard to get to. I just replaced mine this week.
Reply With Quote Quick reply to this message
  #8  
Old 02-06-2010, 04:40 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Location: ithaca
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did it help with power? where did u get the part? dealer? and its called EBP switch? how much it cost? thanks soo much
Reply With Quote Quick reply to this message
  #9  
Old 02-06-2010, 02:50 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Posts: 1,166
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dealer, don't remember price, bought several things. Was not haveing any eng problems, just maintenance. Did not notice any inrease in power.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors