aode - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-02-2009, 01:25 PM Thread Starter Fanatic
Join Date: Oct 2006
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

Hi,this is whisky,i have problem with my 95psd,i was pulling a car from one side of my property and when i got done and unhooked my strap and got back into the truck put it into drive the refused to,it was in 4l,i ran it thru the gears,the
4by indicator said it was in 4l,but when went thru all of the gearing nothing happens it is like there is no transmission in truck.
I could hear a little gear engagement and this on the same day i was going to do a filter and fluid change so the truck beat me to it that is what we are going to do when we get it pulled to the shop,any ideas would be appreaciated short
of a overhaul,thats,whisky
WHISKY6 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome