95 PSD Auto pop-now no movement - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-08-2009, 10:30 AM Thread Starter
Member
 
999renville's Avatar
 
Join Date: Apr 2007
Location: Hutto
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
95 PSD Auto pop-now no movement

OK driving down the road up a slight incline pulling a light motorcycle trailer. I heard a pop and now nothing forward or reverse. Idles and revs fine. Just won't go. just like being in neutral. No grinding or other noises. About 75k since rebuild. any common broken shafts or what should I expect. I'm assuming I'm not in for a standard rebuild?

Jason Renville
Hutto, Texas

94.5 F350 OBS Dually PSD
190k+
10K mod. 3" downpipe
999renville is offline  
post #2 of 4 Old 02-08-2009, 02:02 PM Thread Starter
Member
 
999renville's Avatar
 
Join Date: Apr 2007
Location: Hutto
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
pulled the trans out. input shaft seems tight and not broken. How do I determine if the torque converter is farged? It appears to have been rebuilt as the converter has welds around the perimeter that are still black...not factory welds.

TIA

Jason Renville
Hutto, Texas

94.5 F350 OBS Dually PSD
190k+
10K mod. 3" downpipe
999renville is offline  
post #3 of 4 Old 03-04-2009, 02:27 AM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,256
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
There is another shaft right past the input shaft that commonly breaks. Trans will have to be disassembled to ck. No way to ck the converter.
ipz2222 is offline  
post #4 of 4 Old 03-04-2009, 03:55 PM
Powerstroke.org Fanatic
 
chass350's Avatar
 
Join Date: Sep 2007
Location: Fort Kent
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i had this happen to me one time the splines on the shaft were stripped and the torque converter was messed up to...and it had messed up the planetary gears inside where the input shaft goes in....


1997 Ford F350 7.3, 172,000 miles
Banks Big Hoss chip level 4 (100 HP)
Triple gauge pillar mount
Pyro gauge, Boost gauge, Trans Temp gauge
Banks 3 inch down pipe
straight pipe, cat ran off
33/12.50/16.5 BFG Muds
Detroit Lockers
chass350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome