P1728 need help e4od problems - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-13-2014, 11:26 AM Thread Starter
Member
 
Chaas312's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P1728 need help e4od problems

I bought a 97 f-250 4x4 only 67xxx miles but having trans problems, 1st shifts fine 2nd gear runs up past 3k then slams into 3rd and fully locks the torque converter in so the truck falls on its face, once I get speed up it will shift to o/d when the brake pedal is lightly pressed (just enough to send a brake signal) then when i slow down it doesn't downshift and the converter stays locked right until it's about to stall them downshifts back to 1st, my question is is my trans shot, it shifts and pulls good in 1-2 is it a solenoid or just the converter shot? I have access to snap on scan tools is there anything I need to check also mechanically inclined and have the tools to do myself I'm just not familiar with transmissions I had one code on it p1728 trans slip error converter clutch fault.. And help or advice would be greatly appreciated
Chaas312 is offline  
post #2 of 3 Old 05-15-2014, 05:29 AM
Powerstroke.org Fanatic
 
nra1ifer's Avatar
 
Join Date: Dec 2011
Location: Bentonville, AR
Posts: 113
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Since this is a new-to-you truck, the first thing I would do is a complete transmission service; drain everything including the TC, replace the filter, then fill it with new fluid..... then see how it does.

nra1ifer
1995 F250 Ext. Cab 7.3L PSD

I won't be wronged. I won't be insulted. I won't be laid a-hand on. I don't do these things to other people, and I require the same from them.
nra1ifer is offline  
post #3 of 3 Old 05-15-2014, 06:03 AM Thread Starter
Member
 
Chaas312's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah I've changed all fluids and filter still does the same thing
Chaas312 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome