Weird OD problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-14-2008, 09:56 PM Thread Starter Rookie
Join Date: Nov 2008
Location: El Mirage, AZ
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Weird OD problem

My truck wants to not go into overdrive. When you turn the ignition on the OD light is supposed to be off. Mine is on. It will sometimes shift into od. It has to be electrical. I check for codes with a MT2500 and none. When I did the KOER test the light will go out. I have did all the usual stuff, the shifter wires, took the chip out, took the transcommand out of the loop, everything but this has me stumped. It shifts fine 1-3. I have checked the wiring and can't find anything. When it finally decides it wants to shift into od it will work for a while then when going down the road it will shift out on its own and sometimes you can push the button and it will go back and other times it wont. Can someone jog me to make me think of something that I haven't done?
ChuckD is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome