E4OD probems, can't find anything similar searching, HELP.PLEASE! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-20-2013, 05:40 AM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Sunny Buffalo, NY
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry E4OD probems, can't find anything similar searching, HELP.PLEASE!

I own a small repair company and this truck is one of my favorites, my friends think I nuts, but I just cant give up on her. Being an industrial mechanic this thing is driving me crazy. I hate being just a parts swapper.

96 OBS, 4x4, dually, heavy welding service body, sits about 8000 lbs. 180K

I have been having trouble with the tranny on it since I bought it. I have tried the usual suspects in everything I have read so far. It seems like the TC is coming unlocked and then it starts banging shifts hard. It happens totally erratically. I have found that if I stop and shut the truck off or sometimes just out in park and back in drive, it will shift fine.

-happens in city or highway driving
-when it happens RPMS increase to hold the same speed and I can move the revs all around with the throttle.
-Sometimes shifter light blinks, sometimes not
-Shifts so hard the truck bangs.
-Might go a week , might go a mile
-Standing on the brake with it to the wood, the it revs to about 2K.
-Had local shop put a good used rear end, now it seems to happen more frequently now.
-speedo moves a little, 2-3 mph going 60 MPH. It think this is from when the speedo got the snot beat out of it when my VSS failed and I had to drive it home.


What I done so far;

All OEM parts, no aftermarket

-New shifter position switch and pigtail. Properly adjusted the neutral position switch. Old one was kinda corroded.
-New shifter cable when I replaced the switch.
-new VSS
-Third brake light seems Taillights seem OK.
-Fluid change, just as maintenance, old fluid was still red and smelled fine.
-Standing on the brake with it to the wood, the it revs to about 2K.

My gut tells my electrical, but maybe that's just wish full thinking.

Where should I go from here?

Thanks for your help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-20-2013, 12:14 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: linden, ca
Posts: 306
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
o/d light blinking means there is a trouble code. you should have it scanned before you go any further.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors