99 PSD - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-03-2013, 06:52 AM Thread Starter
Powerstroke.org Rookie
Join Date: May 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 PSD

Well I am new too the diesel world. But I recently bought a late 99 PSD. Guy told me he was having transmission issues, it wouldnt downshift, well he didnt know about the lockup thing, so I got a deal on that but 2 days ago, it started slipping really bad everysince I powerbraked it . When I check the tranny fluid it smells like burnt clutches . My buddy has a E99 truck and hes rebuilt his tranny 1 time before but he has a chip on his truck . My truck is not chipped but it has 251k on it . Motor runs great but tranny is going . It also has TC shutter when it takes off, and when it takes off it feels like your driving a five speed and your riding the mess outta the clutch. Transmission fluid looked dark grey . I think its a little past changing the fluid and the filter . Any thoughts or suggestions ? My buddy has a set of clutches if I need them but what else would I possibly have too replace ? Need some help on this ....
STC1999 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome