Hard shifts...bouncing speedo...cruise disengaging - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 Old 03-12-2012, 12:39 PM Thread Starter
Member
 
Join Date: May 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hard shifts...bouncing speedo...cruise disengaging

Hey all, just pulled truck out to try and get road worthy. Had IDM failure last year and drove in a limp mode about ten miles. Replaced IDM and motor runs fine but tranny is kicking hard on up/down shifts, I mean neck snapping hard! Replaced VSS cause speedo was bouncing above 70, Ford genuine and now speedo is worse and my cruise wont stay engaged above 50 mph. Bounce is about 15 mph at fwy speeds. Pulled rear cover to inspect gear and found 2 slightly damaged teeth about 180 apart on gear. Tranny is also into O/D by 40 mph unless I run truck WOT through the gears, @ WOT tranny shifts smoother also. Dealer had me bypass connector and solder on VSS pins and still same issue. I'm lost, no codes, no O/D light flashing. Don't know anything about trucks history other than the odometer is not correct, people sold it to me were crooked. Any ideas would help. Thanks
Celboy24 is offline  
Sponsored Links
Advertisement
 
post #2 of 25 Old 04-01-2012, 05:42 PM
Powerstroke.org Fanatic
 
virgin stroker's Avatar
 
Join Date: Feb 2012
Location: OCALA , FLORIDA
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
mine does the same thing. did you have a tranny put in? i did. only had the truck 2 months so i do not know if it was doing it prior purchasing it.

Old fat guy with stock truck.(not for long)
I DO NOT DO PICTURES.
I am an equal opprotunity offender. If i offend you then be prepared to kiss my ***
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


95 cclbdw 2wd
6.0 fuel pump and fuel bowl delete ( have all parts need time)done
6.0 intercooler ( have all parts need time)
4.7 zenner mod
IDM 75k mod
Ts 6 position chip
just acquired a long block( wide open performance is on speed dial)
800hp here i come (in 5 years or so)
virgin stroker is offline  
post #3 of 25 Old 04-01-2012, 05:51 PM
Member
 
Join Date: Dec 2010
Location: Ruidoso
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yep.

Bought my truck with a new ford tranny. shifts way early into overdrive unless its floored. so i replaced the vss. and installed 4.11 gears. still have the same porblems. speedo also shakes since i installed the gears also i reprogrammed the speedo. ive been looking for help for months
joeyjarvis23 is offline  
post #4 of 25 Old 04-01-2012, 06:20 PM Thread Starter
Member
 
Join Date: May 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Put in a used cluster...speedo is better but still bouncing...still shifting hard!...off to tranny shop I guess???
Celboy24 is offline  
post #5 of 25 Old 04-01-2012, 06:30 PM
Compression Ignition Addict
 
atvrider93's Avatar
 
Join Date: May 2010
Location: Raleigh, NC
Posts: 3,835
Thanks: 12
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
post up in the OBS flame free zone or OBS chat

1996 F350 4x4 CCLB-- I'll miss her

1996 F350 4X4 RCLB zf5 213K
6637
OBA w/horn
DE 5"
PHP tunes
Mud Country 315/75/16

2008 Wr250X

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
Originally Posted by belz View Post
There u go Tom. John may not be sexy, but he can tutor you, lol.
atvrider93 is offline  
post #6 of 25 Old 04-01-2012, 06:57 PM
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You didn't have anything filled out on your signature so not sure what you are running or if OBS trucks are different, but I havea friend with a SD that had a TruSpeed calibrator go bad on them and cause similar problems. Removed that and the speedo quit bouncing and transmission worked like it was supposed to. He ended up recalibrating the PCM for the speedo after that and tossing the truspeed in the trash.
-Aaron

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!
GreenF350 is offline  
post #7 of 25 Old 04-02-2012, 10:10 AM Thread Starter
Member
 
Join Date: May 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine shifts into O/D by 46 mph...diesel chugs along but same thing unless I'm at WOT...doesnt seem right???

'96 PSD crew long
Celboy24 is offline  
post #8 of 25 Old 04-02-2012, 04:26 PM
Premium Member
 
GreenF350's Avatar
 
Join Date: Jan 2007
Location: Florida Panhandle
Posts: 1,710
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
For what it is worth, my SD locks the converter at 40 and goes into OD at 45, but does go into OD at higher RPMs with more throttle pressure.
-Aaron

2000 Ext. Cab F350 SRW, 6" Skyjacker lift on front/8" BDS Springs on rear w/NO blocks, 37x13.50 Nitto Mud Grappler's, Aftermarket Front Bumper

-Always More Stuff Coming!
GreenF350 is offline  
post #9 of 25 Old 04-03-2012, 05:35 AM
Transmission or Injectors
 
lwillson's Avatar
 
Join Date: Jan 2008
Location: Saskatoon, SK
Posts: 743
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Replace your speedometer (PSOM), they tend to get flaky as they get older, and depending on how rough of a ride they have had, the worse they are.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lwillson is offline  
post #10 of 25 Old 04-03-2012, 08:29 AM Thread Starter
Member
 
Join Date: May 2011
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Just put one in...seems better but still jumping a little...going to try another sensor in diff....problem with original speedo got worse after replacing sensor with OE ford part
Celboy24 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome